summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
commitb0b482a63f92c732c21a7a05f6e91ed9d13d91e6 (patch)
tree5874d7078782459c535f58fd83e3acaff5ea7f72 /kde-base/kdebindings-perl
parentMask KDE SC 4.5 due to missing deps on ppc ppc64 and x86-fbsd. bug #336158 (diff)
downloadgentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.tar.gz
gentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.tar.bz2
gentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.zip
[kde-base] Add KDE SC 4.5.4
(Portage version: 2.2.0_alpha6_p10/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdebindings-perl')
-rw-r--r--kde-base/kdebindings-perl/ChangeLog8
-rw-r--r--kde-base/kdebindings-perl/kdebindings-perl-4.5.4.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/kdebindings-perl/ChangeLog b/kde-base/kdebindings-perl/ChangeLog
index 44d8c5910d6c..782185736e6b 100644
--- a/kde-base/kdebindings-perl/ChangeLog
+++ b/kde-base/kdebindings-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-perl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.6 2010/11/03 16:30:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.7 2010/12/02 21:15:06 alexxy Exp $
+
+*kdebindings-perl-4.5.4 (02 Dec 2010)
+
+ 02 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdebindings-perl-4.5.4.ebuild:
+ Version bump KDE SC 4.5.4
*kdebindings-perl-4.5.3 (03 Nov 2010)
diff --git a/kde-base/kdebindings-perl/kdebindings-perl-4.5.4.ebuild b/kde-base/kdebindings-perl/kdebindings-perl-4.5.4.ebuild
new file mode 100644
index 000000000000..76fabde7f399
--- /dev/null
+++ b/kde-base/kdebindings-perl/kdebindings-perl-4.5.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/kdebindings-perl-4.5.4.ebuild,v 1.1 2010/12/02 21:15:06 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="perl"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE Perl bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi attica debug okular phonon plasma qimageblitz qscintilla qwt semantic-desktop"
+
+DEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smoke 'akonadi?,attica?,multimedia?,okular?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,semantic-desktop?,webkit?')
+ semantic-desktop? ( >=dev-libs/soprano-2.4.64 )
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="smoke"
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}