summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
commitb2b19c584143aa3164437f01988775b3baced7a1 (patch)
treed682b95b673d238fe82f54a47550663464f4e5cd /kde-base/kdeplasma-addons
parentSort test dep. Remove useless dies. (diff)
downloadgentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.tar.gz
gentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.tar.bz2
gentoo-2-b2b19c584143aa3164437f01988775b3baced7a1.zip
Version bump
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog8
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.6.4.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index dfb1f0e92590..42e3d81704d8 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.93 2011/06/10 11:50:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.94 2011/06/10 18:00:12 dilfridge Exp $
+
+*kdeplasma-addons-4.6.4 (10 Jun 2011)
+
+ 10 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdeplasma-addons-4.6.4.ebuild:
+ Version bump
10 Jun 2011; Markos Chandras <hwoarang@gentoo.org>
kdeplasma-addons-4.6.3.ebuild:
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.6.4.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.6.4.ebuild
new file mode 100644
index 000000000000..c2f56c7d8120
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.6.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.6.4.ebuild,v 1.1 2011/06/10 18:00:12 dilfridge Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines."
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif qalculate qwt scim semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'semantic-desktop=')
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep plasma-workspace 'rss')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+# kde-misc/plasmaboard: moved here in 4.3.65
+# kde-misc/qalculate-applet: since 4.4.0
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/plasmaboard
+ !kde-misc/qalculate-applet
+"
+
+# kdebase-data: some svg icons moved from data directly here.
+add_blocker kdebase-data '<4.2.88'
+
+src_prepare() {
+ use semantic-desktop || epatch "${FILESDIR}/${PN}-4.6.2-optional-akonadi.patch"
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}