summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commitdcee7201ef2606358a4f2abc45af713ef2555e5a (patch)
treedac1ea20988f395333c20c4985b60f84f2e71a82 /kde-base/kdeplasma-addons
parentbump to the TeX Live 2011 version (diff)
downloadgentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.gz
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.bz2
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.zip
[kde-base] Version bump KDE SC 4.7.0
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog8
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.7.0.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index 016825851517..e5c112bde8c1 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.97 2011/07/09 15:14:26 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.98 2011/07/27 14:04:49 alexxy Exp $
+
+*kdeplasma-addons-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdeplasma-addons-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
*kdeplasma-addons-4.6.5 (09 Jul 2011)
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.7.0.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.7.0.ebuild
new file mode 100644
index 000000000000..f71285fd509b
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.7.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.7.0.ebuild,v 1.1 2011/07/27 14:04:49 alexxy Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines."
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif qalculate qwt scim semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'semantic-desktop=')
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep plasma-workspace 'rss')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+# kde-misc/plasmaboard: moved here in 4.3.65
+# kde-misc/qalculate-applet: since 4.4.0
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/plasmaboard
+ !kde-misc/qalculate-applet
+"
+
+# kdebase-data: some svg icons moved from data directly here.
+add_blocker kdebase-data '<4.2.88'
+
+src_prepare() {
+ use semantic-desktop || epatch "${FILESDIR}/${PN}-4.6.2-optional-akonadi.patch"
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}