summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-09-16 18:17:35 +0000
committerJohannes Huber <johu@gentoo.org>2014-09-16 18:17:35 +0000
commitf8633b9ab4fbc263024fc7d9e4b25610366de9c2 (patch)
tree6a1fa56dffbbac34e8c5f2f3a57fbdac07646b6c /kde-base/superkaramba/superkaramba-4.14.1.ebuild
parentAlways download/symlink unifont, bug 522956. (diff)
downloadgentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.tar.gz
gentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.tar.bz2
gentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.zip
Version bump KDE SC 4.14.1
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/superkaramba/superkaramba-4.14.1.ebuild')
-rw-r--r--kde-base/superkaramba/superkaramba-4.14.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/superkaramba/superkaramba-4.14.1.ebuild b/kde-base/superkaramba/superkaramba-4.14.1.ebuild
new file mode 100644
index 000000000000..7f53e37bbd02
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.14.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.14.1.ebuild,v 1.1 2014/09/16 18:17:25 johu Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop"
+HOMEPAGE="http://www.kde.org/applications/utilities/superkaramba
+http://utils.kde.org/projects/superkaramba"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ media-libs/qimageblitz
+ x11-libs/libX11
+ x11-libs/libXrender
+ python? (
+ ${PYTHON_DEPS}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython "${PYTHON_USEDEP}") )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}