summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2012-11-20 20:46:41 +0000
committerChristian Faulhammer <fauli@gentoo.org>2012-11-20 20:46:41 +0000
commit9da721bace33efd97ed0ca152e2736e2b2f84bd9 (patch)
tree583fbc88dbfa7b07e2456ab0d6a2ac22a3b317f3 /mail-client/claws-mail-perl
parentStable for x86, wrt bug #441114 (diff)
downloadgentoo-2-9da721bace33efd97ed0ca152e2736e2b2f84bd9.tar.gz
gentoo-2-9da721bace33efd97ed0ca152e2736e2b2f84bd9.tar.bz2
gentoo-2-9da721bace33efd97ed0ca152e2736e2b2f84bd9.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 2B859DE3)
Diffstat (limited to 'mail-client/claws-mail-perl')
-rw-r--r--mail-client/claws-mail-perl/ChangeLog8
-rw-r--r--mail-client/claws-mail-perl/claws-mail-perl-0.9.20.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/mail-client/claws-mail-perl/ChangeLog b/mail-client/claws-mail-perl/ChangeLog
index 7b4eca1c9a80..1cfba6c84feb 100644
--- a/mail-client/claws-mail-perl/ChangeLog
+++ b/mail-client/claws-mail-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-perl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/ChangeLog,v 1.56 2012/05/04 08:42:22 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/ChangeLog,v 1.57 2012/11/20 20:46:41 fauli Exp $
+
+*claws-mail-perl-0.9.20 (20 Nov 2012)
+
+ 20 Nov 2012; Christian Faulhammer <fauli@gentoo.org>
+ +claws-mail-perl-0.9.20.ebuild:
+ version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> claws-mail-perl-0.9.19.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/mail-client/claws-mail-perl/claws-mail-perl-0.9.20.ebuild b/mail-client/claws-mail-perl/claws-mail-perl-0.9.20.ebuild
new file mode 100644
index 000000000000..223537adea51
--- /dev/null
+++ b/mail-client/claws-mail-perl/claws-mail-perl-0.9.20.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/claws-mail-perl-0.9.20.ebuild,v 1.1 2012/11/20 20:46:41 fauli Exp $
+
+MY_P="${PN#claws-mail-}_plugin-${PV}"
+
+DESCRIPTION="Plugin to use perl to write filtering rules"
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.9.0
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ pod2man --section=1 --release=${PV} --name=cm_perl cm_perl.pod > cm_perl.1
+
+ emake -C tools || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doman cm_perl.1
+
+ cd tools
+ exeinto /usr/lib/claws-mail/tools
+ doexe *.pl
+}
+
+pkg_postinst() {
+ echo
+ elog "The documentation for this plugin is contained in a manpage."
+ elog "You can access it with 'man cm_perl'"
+ echo
+}