summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-04-22 19:22:43 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-04-22 19:22:43 +0000
commit9234514749a5b69c66b47f4a306ef37afbaaacb2 (patch)
treec3a5523f24dfe710e975f0fcc17d0313cb2fe98e /media-gfx/freewrl
parentAdd stable candidate without ruby21. (diff)
downloadgentoo-2-9234514749a5b69c66b47f4a306ef37afbaaacb2.tar.gz
gentoo-2-9234514749a5b69c66b47f4a306ef37afbaaacb2.tar.bz2
gentoo-2-9234514749a5b69c66b47f4a306ef37afbaaacb2.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'media-gfx/freewrl')
-rw-r--r--media-gfx/freewrl/ChangeLog8
-rw-r--r--media-gfx/freewrl/freewrl-2.3.3.ebuild134
-rw-r--r--media-gfx/freewrl/freewrl-9999.ebuild11
-rw-r--r--media-gfx/freewrl/metadata.xml1
4 files changed, 147 insertions, 7 deletions
diff --git a/media-gfx/freewrl/ChangeLog b/media-gfx/freewrl/ChangeLog
index 391513d0796c..a4790a29847d 100644
--- a/media-gfx/freewrl/ChangeLog
+++ b/media-gfx/freewrl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/freewrl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/ChangeLog,v 1.55 2014/03/14 13:45:19 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/ChangeLog,v 1.56 2014/04/22 19:22:43 axs Exp $
+
+*freewrl-2.3.3 (22 Apr 2014)
+
+ 22 Apr 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org> +freewrl-2.3.3.ebuild,
+ freewrl-9999.ebuild, metadata.xml:
+ version bump
14 Mar 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+files/freewrl-1.22.13-java-fix.patch, -freewrl-1.22.13-r1.ebuild,
diff --git a/media-gfx/freewrl/freewrl-2.3.3.ebuild b/media-gfx/freewrl/freewrl-2.3.3.ebuild
new file mode 100644
index 000000000000..b5e657f68eea
--- /dev/null
+++ b/media-gfx/freewrl/freewrl-2.3.3.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-2.3.3.ebuild,v 1.1 2014/04/22 19:22:43 axs Exp $
+
+EAPI=5
+
+inherit nsplugins eutils flag-o-matic java-pkg-opt-2 multilib
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.code.sf.net/p/freewrl/git"
+ S="${WORKDIR}/${P}/freex3d"
+ SRC_URI=
+ KEYWORDS=
+else
+ SRC_URI="mirror://sourceforge/freewrl/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="VRML97 and X3D compliant browser, library, and web-browser plugin"
+HOMEPAGE="http://freewrl.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="curl debug java libeai motif +nsplugin opencl osc +sox static-libs"
+
+COMMONDEPEND="x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libX11
+ motif? ( x11-libs/motif )
+ !motif? ( x11-libs/libXaw )
+ media-libs/mesa
+ virtual/opengl
+ media-libs/libpng
+ virtual/jpeg
+ media-libs/imlib2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ curl? ( net-misc/curl )
+ osc? ( media-libs/liblo )
+ opencl? ( virtual/opencl )
+ dev-lang/spidermonkey:0="
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.4 )
+ nsplugin? ( net-misc/npapi-sdk )"
+RDEPEND="${COMMONDEPEND}
+ media-fonts/dejavu
+ || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick] )
+ app-arch/unzip
+ java? ( >=virtual/jre-1.4 )
+ sox? ( media-sound/sox )"
+
+src_configure() {
+ # list of js libs without .pc support, to disable ./configure auto-checking
+ local spidermonkeys=( mozilla-js xulrunner-js firefox-js firefox2-js seamonkey-js )
+ # list of .pc supported spidermonkeys, to disable ./configure auto-checking
+ local spidermonkeys_pc=( mozjs187 mozjs185 )
+
+ local myconf="--enable-fontconfig
+ --without-expat
+ --with-x
+ --with-imageconvert=/usr/bin/convert
+ --with-unzip=/usr/bin/unzip
+ ${spidermonkeys[@]/#/ --disable-}"
+
+ if has_version "<dev-lang/spidermonkey-1.8.5" ; then
+ # spidermonkey pre-1.8.5 has no pkg-config, so override ./configure
+ myconf+="${spidermonkeys_pc[@]/#/ --disable-}"
+ JAVASCRIPT_ENGINE_CFLAGS="-I/usr/include/js -DXP_UNIX"
+ if has_version ">=dev-lang/spidermonkey-1.8:0" ; then
+ # spidermonkey-1.8 changed the name of the lib
+ JAVASCRIPT_ENGINE_LIBS="-lmozjs"
+ else
+ JAVASCRIPT_ENGINE_LIBS="-ljs"
+ fi
+ if has_version "dev-lang/spidermonkey:0[threadsafe]" ; then
+ JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $(pkg-config --cflags nspr)"
+ JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
+ fi
+ export JAVASCRIPT_ENGINE_CFLAGS
+ export JAVASCRIPT_ENGINE_LIBS
+ fi
+ if use nsplugin; then
+ myconf+=" --with-plugindir=/usr/$(get_libdir)/${PLUGINS_DIR}"
+ myconf+=" --disable-mozilla-plugin --disable-xulrunner-plugin"
+ fi
+ econf ${myconf} \
+ $(use_enable curl libcurl) \
+ $(use_with opencl OpenCL) \
+ $(use_enable debug) $(use_enable debug thread_colorized) \
+ $(use_enable libeai) \
+ $(use_enable java) \
+ $(use_enable nsplugin plugin) \
+ $(use_enable osc) \
+ $(use_enable static-libs static) \
+ $(use_enable sox sound) \
+ $(usex sox "--with-soundconv=/usr/bin/sox") \
+ $(usex motif "--with-target=motif" "--with-target=x11") \
+ $(usex motif "--with-statusbar=standard" "--with-statusbar=hud")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use java; then
+ insinto /usr/share/${PN}/lib
+ doins src/java/java.policy
+ java-pkg_regjar src/java/vrml.jar
+ # install vrml.jar as a JRE extension
+ dodir /usr/java/packages/lib/ext
+ dosym /usr/share/${PN}/lib/vrml.jar /usr/java/packages/lib/ext/vrml.jar
+ if ! has_version "media-gfx/freewrl[java]" ; then
+ elog "Because vrml.jar requires access to sockets, you will need to incorporate the"
+ elog "contents of /usr/share/${PN}/lib/java.policy into your system or user's default"
+ elog "java policy:"
+ elog " cat /usr/share/${PN}/lib/java.policy >>~/.java.policy"
+ fi
+ fi
+
+ # remove unneeded .la files (as per Flameeyes' rant)
+ cd "${D}"
+ rm "usr/$(get_libdir)"/*.la "usr/$(get_libdir)/${PLUGINS_DIR}"/*.la
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "By default, FreeWRL expects to find the 'firefox' binary in your include"
+ elog "path. If you do not have firefox installed or you wish to use a different"
+ elog "web browser to open links that are within VRML / X3D files, please be sure to"
+ elog "specify the command via your BROWSER environment variable."
+ fi
+}
diff --git a/media-gfx/freewrl/freewrl-9999.ebuild b/media-gfx/freewrl/freewrl-9999.ebuild
index d28a42f27e8a..d70f472f265f 100644
--- a/media-gfx/freewrl/freewrl-9999.ebuild
+++ b/media-gfx/freewrl/freewrl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-9999.ebuild,v 1.5 2014/03/14 13:45:19 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-9999.ebuild,v 1.6 2014/04/22 19:22:43 axs Exp $
EAPI=5
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]]; then
SRC_URI=
KEYWORDS=
else
- SRC_URI="mirror://sourceforge/freewrl/${P}.1.tar.bz2"
+ SRC_URI="mirror://sourceforge/freewrl/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
@@ -21,7 +21,7 @@ DESCRIPTION="VRML97 and X3D compliant browser, library, and web-browser plugin"
HOMEPAGE="http://freewrl.sourceforge.net/"
LICENSE="GPL-3"
SLOT="0"
-IUSE="curl debug +glew java libeai motif +nsplugin osc +sox static-libs"
+IUSE="curl debug java libeai motif +nsplugin opencl osc +sox static-libs"
COMMONDEPEND="x11-libs/libXau
x11-libs/libXdmcp
@@ -30,7 +30,6 @@ COMMONDEPEND="x11-libs/libXau
motif? ( x11-libs/motif )
!motif? ( x11-libs/libXaw )
media-libs/mesa
- glew? ( media-libs/glew )
virtual/opengl
media-libs/libpng
virtual/jpeg
@@ -39,6 +38,7 @@ COMMONDEPEND="x11-libs/libXau
media-libs/fontconfig
curl? ( net-misc/curl )
osc? ( media-libs/liblo )
+ opencl? ( virtual/opencl )
dev-lang/spidermonkey:0="
DEPEND="${COMMONDEPEND}
virtual/pkgconfig
@@ -69,7 +69,6 @@ src_configure() {
local myconf="--enable-fontconfig
--without-expat
- --without-glu
--with-x
--with-imageconvert=/usr/bin/convert
--with-unzip=/usr/bin/unzip
@@ -99,7 +98,7 @@ src_configure() {
fi
econf ${myconf} \
$(use_enable curl libcurl) \
- $(use_with glew) \
+ $(use_with opencl OpenCL) \
$(use_enable debug) $(use_enable debug thread_colorized) \
$(use_enable libeai) \
$(use_enable java) \
diff --git a/media-gfx/freewrl/metadata.xml b/media-gfx/freewrl/metadata.xml
index 2dd4b2b92242..5bd1781fdc55 100644
--- a/media-gfx/freewrl/metadata.xml
+++ b/media-gfx/freewrl/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name='glew'>Enable glew extensions</flag>
<flag name='libeai'>Build EAI C library</flag>
+ <flag name='opencl'>Enable OpenCL support</flag>
<flag name='osc'>Allows for OSC-based control and communication between multiple freewrl instances</flag>
<flag name='java'>Build and install java EAI/SAI support library</flag>
</use>