summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-11-04 11:23:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-11-04 11:23:08 +0000
commitc938b99b33370a9772820c0e0a547ede8312a898 (patch)
tree15ec65cf4ab8aa655c2efe445b03330712d1c5fa /media-libs/libfishsound
parentamd64 stable, bug #282549 (diff)
downloadgentoo-2-c938b99b33370a9772820c0e0a547ede8312a898.tar.gz
gentoo-2-c938b99b33370a9772820c0e0a547ede8312a898.tar.bz2
gentoo-2-c938b99b33370a9772820c0e0a547ede8312a898.zip
version bump
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libfishsound')
-rw-r--r--media-libs/libfishsound/ChangeLog8
-rw-r--r--media-libs/libfishsound/libfishsound-0.9.2.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/media-libs/libfishsound/ChangeLog b/media-libs/libfishsound/ChangeLog
index 424781bdc40b..ee3024069e87 100644
--- a/media-libs/libfishsound/ChangeLog
+++ b/media-libs/libfishsound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libfishsound
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/ChangeLog,v 1.6 2009/09/14 21:24:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/ChangeLog,v 1.7 2009/11/04 11:23:08 aballier Exp $
+
+*libfishsound-0.9.2 (04 Nov 2009)
+
+ 04 Nov 2009; Alexis Ballier <aballier@gentoo.org>
+ +libfishsound-0.9.2.ebuild:
+ version bump
14 Sep 2009; Markus Meier <maekke@gentoo.org> libfishsound-0.9.1.ebuild:
amd64/x86 stable, bug #284380
diff --git a/media-libs/libfishsound/libfishsound-0.9.2.ebuild b/media-libs/libfishsound/libfishsound-0.9.2.ebuild
new file mode 100644
index 000000000000..9bd02f25aa1a
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-0.9.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/libfishsound-0.9.2.ebuild,v 1.1 2009/11/04 11:23:08 aballier Exp $
+
+DESCRIPTION="Simple programming interface for decoding and encoding audio data using vorbis or speex"
+HOMEPAGE="http://www.annodex.net/software/libfishsound/html/"
+SRC_URI="http://www.annodex.net/software/libfishsound/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc speex"
+
+RDEPEND="media-libs/libvorbis media-libs/libogg
+ speex? ( media-libs/speex )"
+# flac? ( media-libs/flac )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen virtual/latex-base )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use doc || sed -i -e "s/doxygen/doxygen-dummy/" configure
+ rm -rf "${S}/doc/libfishsound"
+}
+
+src_compile() {
+ local myconf=""
+ # use flac ||
+ # disable it for now, it causes compile failures in sonic-visualiser because
+ # it adds -I/usr/include/FLAC to pkgconfig cflags...
+ myconf="$myconf --disable-flac"
+ use speex || myconf="$myconf --disable-speex"
+ econf $myconf
+
+ emake || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ cd "${S}/doc/libfishsound/latex"
+ emake refman.ps || die "failed to create refman.ps"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}