summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-01-23 14:08:20 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2015-01-23 14:08:20 +0000
commit9c966e9fd4d0b5030f3931e07bba27178da07718 (patch)
tree301ccf1cb7fc60e42eb408122032fdffc7878456 /media-radio
parentVersion bump. (diff)
downloadgentoo-2-9c966e9fd4d0b5030f3931e07bba27178da07718.tar.gz
gentoo-2-9c966e9fd4d0b5030f3931e07bba27178da07718.tar.bz2
gentoo-2-9c966e9fd4d0b5030f3931e07bba27178da07718.zip
Verrsion bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/unixcw/ChangeLog7
-rw-r--r--media-radio/unixcw/unixcw-3.4.1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/media-radio/unixcw/ChangeLog b/media-radio/unixcw/ChangeLog
index 85a318e2d584..4f5502e9c0d6 100644
--- a/media-radio/unixcw/ChangeLog
+++ b/media-radio/unixcw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/unixcw
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.22 2015/01/17 14:02:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.23 2015/01/23 14:08:20 tomjbe Exp $
+
+*unixcw-3.4.1 (23 Jan 2015)
+
+ 23 Jan 2015; Thomas Beierlein <tomjbe@gentoo.org> +unixcw-3.4.1.ebuild:
+ Version bump
17 Jan 2015; Agostino Sarubbo <ago@gentoo.org> unixcw-3.4.0.ebuild:
Stable for ppc, wrt bug #535484
diff --git a/media-radio/unixcw/unixcw-3.4.1.ebuild b/media-radio/unixcw/unixcw-3.4.1.ebuild
new file mode 100644
index 000000000000..737807fa3e8f
--- /dev/null
+++ b/media-radio/unixcw/unixcw-3.4.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/unixcw-3.4.1.ebuild,v 1.1 2015/01/23 14:08:20 tomjbe Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="A package of programs that fit together to form a morse code tutor program"
+HOMEPAGE="http://unixcw.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="alsa ncurses pulseaudio suid qt4"
+
+RDEPEND="ncurses? ( sys-libs/ncurses )
+ qt4? ( dev-qt/qtgui:4[qt3support] )
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ !<=app-misc/cw-1.0.16-r1"
+
+src_prepare() {
+ append-cflags -std=gnu99
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) \
+ $(use_enable pulseaudio ) \
+ $(use_enable alsa ) \
+ $(use_enable ncurses cwcp ) \
+ $(use_enable qt4 xcwcp )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+ dodoc ChangeLog NEWS README
+ if ! use suid ; then
+ fperms 711 /usr/bin/cw
+ if use ncurses ; then
+ fperms 711 /usr/bin/cwcp
+ fi
+ if use qt4 ; then
+ fperms 711 /usr/bin/xcwcp
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use suid ; then
+ ewarn "You have choosen to install 'cw', 'cwcp' and 'xcwcp' setuid"
+ ewarn "by setting USE=suid."
+ ewarn "Be aware that this is a security risk and not recommended."
+ ewarn ""
+ ewarn "These files do only need root access if you want to use the"
+ ewarn "PC speaker for morse sidetone output. You can alternativly"
+ ewarn "drop USE=suid and use sudo."
+ else
+ elog "Be aware that 'cw', 'cwcp' and 'xcwcp' needs root access if"
+ elog "you want to use the PC speaker for morse sidetone output."
+ elog "You can call the programs via sudo for that (see 'man sudo')."
+ fi
+}