summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-01-14 17:32:27 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-01-14 17:32:27 +0000
commit08f001792c69879e66f02783523c4533bbbc39e2 (patch)
tree372877122f15280a83f73a43d769299327a75046 /media-tv/nuppelvideo
parentStable on x86. (diff)
downloadgentoo-2-08f001792c69879e66f02783523c4533bbbc39e2.tar.gz
gentoo-2-08f001792c69879e66f02783523c4533bbbc39e2.tar.bz2
gentoo-2-08f001792c69879e66f02783523c4533bbbc39e2.zip
Fixing #77404 (gcc 3.4 trouble)
Diffstat (limited to 'media-tv/nuppelvideo')
-rw-r--r--media-tv/nuppelvideo/ChangeLog8
-rw-r--r--media-tv/nuppelvideo/files/gcc3.4.patch93
-rw-r--r--media-tv/nuppelvideo/nuppelvideo-0.52a.ebuild16
3 files changed, 112 insertions, 5 deletions
diff --git a/media-tv/nuppelvideo/ChangeLog b/media-tv/nuppelvideo/ChangeLog
index e2ffc3991251..52097fa5fee1 100644
--- a/media-tv/nuppelvideo/ChangeLog
+++ b/media-tv/nuppelvideo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/nuppelvideo
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nuppelvideo/ChangeLog,v 1.2 2004/06/25 00:33:03 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nuppelvideo/ChangeLog,v 1.3 2005/01/14 17:32:27 phosphan Exp $
+
+ 14 Jan 2005; Patrick Kursawe <phosphan@gentoo.org> +files/gcc3.4.patch,
+ nuppelvideo-0.52a.ebuild:
+ Fixing gcc 3.4 compile problems, see bug #77404
*nuppelvideo-0.52a (02 Sep 2003)
diff --git a/media-tv/nuppelvideo/files/gcc3.4.patch b/media-tv/nuppelvideo/files/gcc3.4.patch
new file mode 100644
index 000000000000..a41ff5eea765
--- /dev/null
+++ b/media-tv/nuppelvideo/files/gcc3.4.patch
@@ -0,0 +1,93 @@
+diff -ru ../NuppelVideo-0.52a.orig/./RTjpegN.c ./RTjpegN.c
+--- ../NuppelVideo-0.52a.orig/./RTjpegN.c 2001-07-02 23:55:42.000000000 +0200
++++ ./RTjpegN.c 2005-01-14 18:15:50.042499084 +0100
+@@ -136,7 +136,8 @@
+ register __s16 ZZvalue;
+ register unsigned char bitten;
+ register unsigned char bitoff;
+-
++ register __u8 *ustrm;
++ ustrm = (__u8 *)strm;
+ #ifdef SHOWBLOCK
+
+ int ii;
+@@ -153,7 +154,7 @@
+ // return 2;
+
+ // first byte allways written
+- (__u8)strm[0]=
++ ustrm[0]=
+ (__u8)(data[RTjpeg_ZZ[0]]>254) ? 254:((data[RTjpeg_ZZ[0]]<0)?0:data[RTjpeg_ZZ[0]]);
+
+
+@@ -163,7 +164,7 @@
+ bitten = ((unsigned char)ci) << 2;
+
+ if (ci==0) {
+- (__u8)strm[1]= bitten;
++ ustrm[1]= bitten;
+ co = 2;
+ return (int)co;
+ }
+@@ -192,7 +193,7 @@
+ }
+
+ if( bitoff == 0 ) {
+- (__u8)strm[co]= bitten;
++ ustrm[co]= bitten;
+ bitten = 0;
+ bitoff = 8;
+ co++;
+@@ -204,7 +205,7 @@
+ /* ci must be 0 */
+ if(bitoff != 6) {
+
+- (__u8)strm[co]= bitten;
++ ustrm[co]= bitten;
+ co++;
+
+ }
+@@ -221,7 +222,7 @@
+ break;
+ case 2:
+ case 0:
+- (__u8)strm[co]= bitten;
++ ustrm[co]= bitten;
+ bitoff = 4;
+ co++;
+ bitten = 0; // clear half nibble values in bitten
+@@ -242,7 +243,7 @@
+ bitten |= (ZZvalue&0xf)<<bitoff;
+
+ if( bitoff == 0 ) {
+- (__u8)strm[co]= bitten;
++ ustrm[co]= bitten;
+ bitten = 0;
+ bitoff = 8;
+ co++;
+@@ -252,14 +253,14 @@
+
+ /* ci must be 0 */
+ if( bitoff == 0 ) {
+- (__u8)strm[co]= bitten;
++ ustrm[co]= bitten;
+ co++;
+ }
+ goto BAUCHWEH;
+
+ HIRNWEH:
+
+- (__u8)strm[co]= bitten;
++ ustrm[co]= bitten;
+ co++;
+
+
+@@ -352,7 +353,7 @@
+ data[i]= 0;
+ break;
+ default:
+-
++ ;
+ }
+
+ if( bitoff == 0 ) {
diff --git a/media-tv/nuppelvideo/nuppelvideo-0.52a.ebuild b/media-tv/nuppelvideo/nuppelvideo-0.52a.ebuild
index 043bafa2f34c..dac7bd5b0da6 100644
--- a/media-tv/nuppelvideo/nuppelvideo-0.52a.ebuild
+++ b/media-tv/nuppelvideo/nuppelvideo-0.52a.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nuppelvideo/nuppelvideo-0.52a.ebuild,v 1.3 2004/06/25 00:33:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nuppelvideo/nuppelvideo-0.52a.ebuild,v 1.4 2005/01/14 17:32:27 phosphan Exp $
+
+inherit eutils
MY_P=NuppelVideo-${PV}
S=${WORKDIR}/${MY_P}
@@ -13,9 +15,17 @@ SLOT="0"
IUSE=""
KEYWORDS="x86"
-DEPEND="virtual/os-headers"
+DEPEND="virtual/os-headers
+ >=sys-apps/sed-4"
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gcc3.4.patch
+ sed -e 's:^CFLAGS.*::' -i Makefile || die "sed failed"
+}
+
src_compile() {
emake || die
}