summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2002-10-24 07:10:09 +0000
committerZack Welch <zwelch@gentoo.org>2002-10-24 07:10:09 +0000
commitc73918ede10b584053403ac7bc65ba78148e7502 (patch)
treeee1f919a9d6eaaacfcf96add7e4d5fe300334f86 /media-video/w3cam
parenttasty fun ebuild fixage, see ChangeLog (diff)
downloadgentoo-2-c73918ede10b584053403ac7bc65ba78148e7502.tar.gz
gentoo-2-c73918ede10b584053403ac7bc65ba78148e7502.tar.bz2
gentoo-2-c73918ede10b584053403ac7bc65ba78148e7502.zip
new ebuild, see bug 7086
Diffstat (limited to 'media-video/w3cam')
-rw-r--r--media-video/w3cam/ChangeLog22
-rw-r--r--media-video/w3cam/files/digest-w3cam-0.7.21
-rw-r--r--media-video/w3cam/w3cam-0.7.2.ebuild53
3 files changed, 76 insertions, 0 deletions
diff --git a/media-video/w3cam/ChangeLog b/media-video/w3cam/ChangeLog
new file mode 100644
index 000000000000..defa360d81db
--- /dev/null
+++ b/media-video/w3cam/ChangeLog
@@ -0,0 +1,22 @@
+# ChangeLog for media-video/w3cam
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/ChangeLog,v 1.1 2002/10/24 07:10:09 zwelch Exp $
+
+*w3cam-0.7.2-r1 (23 Oct 2002)
+
+ 24 Oct 2002; Zach Welch <zwelch@gentoo.org> :
+ minor cleanup of ebuild and commit to CVS
+
+ 23 Oct 2002; Burton Samograd <kruhft@kruhft.dyndns.org> ChangeLog,
+ w3cam-0.7.2-r1.ebuild :
+ Updated SRC_URI and HOMEPAGE as the original author seems to have
+ resurfaced on the web.
+ Updated configure section by adding --with-ttf-inc flag, as it was
+ having problems with finding freetype headers.
+
+*w3cam-0.7.2 (25 Aug 2002)
+
+ 25 Aug 2002; Burton Samograd <kruhft@kruhft.dyndns.org> ChangeLog,
+ w3cam-0.7.2.ebuild, files/digest-w3cam-0.7.2 :
+ New ebuild. w3cam is a set of CLI programs for grabbing images
+ and videos from video4linux (v4l) devices.
diff --git a/media-video/w3cam/files/digest-w3cam-0.7.2 b/media-video/w3cam/files/digest-w3cam-0.7.2
new file mode 100644
index 000000000000..8e9eb837c94e
--- /dev/null
+++ b/media-video/w3cam/files/digest-w3cam-0.7.2
@@ -0,0 +1 @@
+MD5 eec0b301b32bc8e9f65a4e54248c9868 w3cam-0.7.2.tar.gz 144712
diff --git a/media-video/w3cam/w3cam-0.7.2.ebuild b/media-video/w3cam/w3cam-0.7.2.ebuild
new file mode 100644
index 000000000000..f4045e0dd934
--- /dev/null
+++ b/media-video/w3cam/w3cam-0.7.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.1 2002/10/24 07:10:09 zwelch Exp $
+
+#
+# You can set the default device that vidcat and w3camd use by setting
+# the environment variable W3CAM_DEVCE when emerging.
+# eg.
+#
+# W3CAM_DEVICE="/dev/video0" emerge w3cam
+#
+
+S=${WORKDIR}/${P}
+DESCRIPTION="w3cam - a set of small programs to grab images and videos from video4linux devices"
+HOMEPAGE="http://mpx.freeshell.org/"
+SRC_URI="http://mpx.freeshell.org/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc \
+ zlib? sys-libs/zlib \
+ jpeg? media-libs/jpeg \
+ png? media-libs/libpng \
+ truetype? media-libs/freetype"
+
+src_compile() {
+ local myconf
+
+ test -z ${W3CAM_DEVICE} \
+ || myconf="${myconf} --with-device=${W3CAM_DEVICE}"
+
+ use truetype \
+ || myconf="${myconf} --with-ttf-inc=/usr/include/freetype"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man/man1 \
+ ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dobin vidcat w3camd/w3camd
+ doman vidcat.1
+ dodoc COPYING.txt ChangeLog.txt FAQ.txt README SAMPLES TODO.txt \
+ index.html w3cam.css w3cam.cgi w3cam.cgi.scf
+ docinto samples
+ dodoc samples/*
+ docinto w3camd
+ dodoc w3camd/README w3camd/index.html w3camd/test.html w3camd/w3camd.fig
+}
+