summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-11 10:24:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-11 10:24:45 +0000
commit7b706e1636e2b82c7f6e1a618f218db2da70d370 (patch)
tree6f14ce55ca9fe3d09d6b53ff347a8ad47d27ea17 /media-video
parentClean up old revisions. (diff)
downloadgentoo-2-7b706e1636e2b82c7f6e1a618f218db2da70d370.tar.gz
gentoo-2-7b706e1636e2b82c7f6e1a618f218db2da70d370.tar.bz2
gentoo-2-7b706e1636e2b82c7f6e1a618f218db2da70d370.zip
Use python-single-r1.eclass (instead of the deprecated python.eclass)
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subdl/ChangeLog8
-rw-r--r--media-video/subdl/subdl-1.0.3.ebuild19
2 files changed, 15 insertions, 12 deletions
diff --git a/media-video/subdl/ChangeLog b/media-video/subdl/ChangeLog
index 58f5b9f22516..bfe14fe97eb1 100644
--- a/media-video/subdl/ChangeLog
+++ b/media-video/subdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/subdl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subdl/ChangeLog,v 1.2 2010/11/02 21:15:32 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subdl/ChangeLog,v 1.3 2013/08/11 10:24:45 ssuominen Exp $
+
+ 11 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> subdl-1.0.3.ebuild:
+ Use python-single-r1.eclass (instead of the deprecated python.eclass)
*subdl-1.0.3 (02 Nov 2010)
@@ -11,4 +14,3 @@
25 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> +subdl-1.0.2.ebuild:
Initial commit.
-
diff --git a/media-video/subdl/subdl-1.0.3.ebuild b/media-video/subdl/subdl-1.0.3.ebuild
index 6ae8b749c820..17a87db67e2e 100644
--- a/media-video/subdl/subdl-1.0.3.ebuild
+++ b/media-video/subdl/subdl-1.0.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subdl/subdl-1.0.3.ebuild,v 1.1 2010/11/02 21:15:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subdl/subdl-1.0.3.ebuild,v 1.2 2013/08/11 10:24:45 ssuominen Exp $
-EAPI=2
-PYTHON_DEPEND="2:2.6"
-inherit python
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
DESCRIPTION="A command-line tool for downloading subs from opensubtitles.org"
HOMEPAGE="http://code.google.com/p/subdl/"
@@ -15,16 +15,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=""
-DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}
src_prepare() {
- python_convert_shebangs 2 ${PN}
+ python_fix_shebang ${PN}
}
src_install() {
- dobin ${PN} || die
+ dobin ${PN}
dodoc README.txt
}