summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-05-07 21:13:54 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-05-07 21:13:54 +0000
commitddce160af75fd556b08c5db77cb80b7d29d35219 (patch)
treec0d384c6b3866267e02bf8a738424ef1f17f8a19 /net-analyzer/nmapsi
parentVersion bump, remove old. (diff)
downloadgentoo-2-ddce160af75fd556b08c5db77cb80b7d29d35219.tar.gz
gentoo-2-ddce160af75fd556b08c5db77cb80b7d29d35219.tar.bz2
gentoo-2-ddce160af75fd556b08c5db77cb80b7d29d35219.zip
Version bump.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nmapsi')
-rw-r--r--net-analyzer/nmapsi/ChangeLog10
-rw-r--r--net-analyzer/nmapsi/files/nmapsi-0.3.1-gcc-4.7.patch10
-rw-r--r--net-analyzer/nmapsi/nmapsi-0.3.1.ebuild32
3 files changed, 50 insertions, 2 deletions
diff --git a/net-analyzer/nmapsi/ChangeLog b/net-analyzer/nmapsi/ChangeLog
index 037bbdadaaa4..4a02028aa4eb 100644
--- a/net-analyzer/nmapsi/ChangeLog
+++ b/net-analyzer/nmapsi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nmapsi
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/ChangeLog,v 1.5 2011/08/28 11:31:10 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/ChangeLog,v 1.6 2012/05/07 21:13:54 kensington Exp $
+
+*nmapsi-0.3.1 (07 May 2012)
+
+ 07 May 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/nmapsi-0.3.1-gcc-4.7.patch, +nmapsi-0.3.1.ebuild:
+ Version bump.
*nmapsi-0.2.1 (28 Aug 2011)
diff --git a/net-analyzer/nmapsi/files/nmapsi-0.3.1-gcc-4.7.patch b/net-analyzer/nmapsi/files/nmapsi-0.3.1-gcc-4.7.patch
new file mode 100644
index 000000000000..e7606a8cb2be
--- /dev/null
+++ b/net-analyzer/nmapsi/files/nmapsi-0.3.1-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- nmapsi4/app/preference/profilemain.h
++++ nmapsi4/app/preference/profilemain.h
+@@ -28,6 +28,7 @@
+ // local include
+ #include "utilities.h"
+ #include <ui_profilemain.h>
++#include <unistd.h>
+
+ class mainProfile : public QDialog, private Ui::ProfileMain
+ {
diff --git a/net-analyzer/nmapsi/nmapsi-0.3.1.ebuild b/net-analyzer/nmapsi/nmapsi-0.3.1.ebuild
new file mode 100644
index 000000000000..f317365607e1
--- /dev/null
+++ b/net-analyzer/nmapsi/nmapsi-0.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/nmapsi-0.3.1.ebuild,v 1.1 2012/05/07 21:13:54 kensington Exp $
+
+EAPI=4
+inherit base cmake-utils
+
+MY_P=${PN}4-${PV/_/-}
+
+DESCRIPTION="A Qt4 frontend to nmap"
+HOMEPAGE="http://www.nmapsi4.org/"
+SRC_URI="http://nmapsi4.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4"
+RDEPEND="${DEPEND}
+ net-analyzer/nmap"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS NEWS README TODO Translation )
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-4.7.patch"
+)