summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-05-31 08:32:26 +0000
committerJeroen Roovers <jer@gentoo.org>2015-05-31 08:32:26 +0000
commit1ca45a007f558ef6ccd3bfe1b70e7cd9c2432580 (patch)
treefce371b859812403b55bed3e64ce3e77a5f52b34 /net-analyzer
parentarm stable wrt bug #550032 (diff)
downloadgentoo-2-1ca45a007f558ef6ccd3bfe1b70e7cd9c2432580.tar.gz
gentoo-2-1ca45a007f558ef6ccd3bfe1b70e7cd9c2432580.tar.bz2
gentoo-2-1ca45a007f558ef6ccd3bfe1b70e7cd9c2432580.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/darkstat/ChangeLog9
-rw-r--r--net-analyzer/darkstat/darkstat-3.0.719.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/net-analyzer/darkstat/ChangeLog b/net-analyzer/darkstat/ChangeLog
index ca6fc0351ff8..3556e65af065 100644
--- a/net-analyzer/darkstat/ChangeLog
+++ b/net-analyzer/darkstat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/darkstat
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/darkstat/ChangeLog,v 1.66 2014/08/15 19:18:31 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/darkstat/ChangeLog,v 1.67 2015/05/31 08:32:26 jer Exp $
+
+*darkstat-3.0.719 (31 May 2015)
+
+ 31 May 2015; Jeroen Roovers <jer@gentoo.org> +darkstat-3.0.719.ebuild:
+ Version bump.
15 Aug 2014; Jeroen Roovers <jer@gentoo.org> darkstat-3.0.718.ebuild:
sed must die().
diff --git a/net-analyzer/darkstat/darkstat-3.0.719.ebuild b/net-analyzer/darkstat/darkstat-3.0.719.ebuild
new file mode 100644
index 000000000000..9859276eafa9
--- /dev/null
+++ b/net-analyzer/darkstat/darkstat-3.0.719.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/darkstat/darkstat-3.0.719.ebuild,v 1.1 2015/05/31 08:32:26 jer Exp $
+
+EAPI=5
+inherit autotools eutils user
+
+DESCRIPTION="Network traffic analyzer with cute web interface"
+HOMEPAGE="http://unix4lyfe.org/darkstat/"
+SRC_URI="http://unix4lyfe.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+DARKSTAT_CHROOT_DIR=${DARKSTAT_CHROOT_DIR:-/var/lib/darkstat}
+
+DOCS=( AUTHORS ChangeLog README NEWS )
+
+src_prepare() {
+ sed -i -e 's|-flto||g' configure.ac || die
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-debug --with-privdrop-user=darkstat
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/darkstat-initd darkstat
+ newconfd "${FILESDIR}"/darkstat-confd darkstat
+
+ sed -i -e "s:__CHROOT__:${DARKSTAT_CHROOT_DIR}:g" "${D}"/etc/conf.d/darkstat || die
+ sed -i -e "s:__CHROOT__:${DARKSTAT_CHROOT_DIR}:g" "${D}"/etc/init.d/darkstat || die
+
+ keepdir "${DARKSTAT_CHROOT_DIR}"
+ chown darkstat:0 "${D}${DARKSTAT_CHROOT_DIR}"
+}
+
+pkg_preinst() {
+ enewuser darkstat
+}
+
+pkg_postinst() {
+ # Workaround bug #141619
+ DARKSTAT_CHROOT_DIR=`sed -n 's/^#CHROOT=\(.*\)/\1/p' "${ROOT}"etc/conf.d/darkstat`
+ chown darkstat:0 "${ROOT}${DARKSTAT_CHROOT_DIR}"
+
+ elog "To start different darkstat instances which will listen on a different"
+ elog "interfaces create in /etc/init.d directory the 'darkstat.if' symlink to"
+ elog "darkstat script where 'if' is the name of the interface."
+ elog "Also in /etc/conf.d directory copy darkstat to darkstat.if"
+ elog "and edit it to change default values."
+ elog
+ elog "darkstat's default chroot directory is: \"${ROOT}${DARKSTAT_CHROOT_DIR}\""
+}