summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-04-15 11:36:51 +0000
committerAlin Năstac <mrness@gentoo.org>2007-04-15 11:36:51 +0000
commit631612221fef85c130035e04d014ea6dfa47017b (patch)
tree06eb25b67b3857f4e09bb767cbdf9054b4a713d0 /net-dialup
parentFix implicit declaration warning (diff)
downloadgentoo-2-631612221fef85c130035e04d014ea6dfa47017b.tar.gz
gentoo-2-631612221fef85c130035e04d014ea6dfa47017b.tar.bz2
gentoo-2-631612221fef85c130035e04d014ea6dfa47017b.zip
Fix implicit declaration warnings.
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xc/ChangeLog8
-rw-r--r--net-dialup/xc/files/xc-4.3.2-implicit-decl.patch23
-rw-r--r--net-dialup/xc/xc-4.3.2-r1.ebuild5
3 files changed, 32 insertions, 4 deletions
diff --git a/net-dialup/xc/ChangeLog b/net-dialup/xc/ChangeLog
index ed6f4daa5d71..ba7ed8734125 100644
--- a/net-dialup/xc/ChangeLog
+++ b/net-dialup/xc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/xc
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/ChangeLog,v 1.18 2006/09/23 16:45:43 mrness Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/ChangeLog,v 1.19 2007/04/15 11:36:51 mrness Exp $
+
+ 15 Apr 2007; Alin Năstac <mrness@gentoo.org>
+ +files/xc-4.3.2-implicit-decl.patch, xc-4.3.2-r1.ebuild:
+ Fix implicit declaration warnings.
23 Sep 2006; Alin Nastac <mrness@gentoo.org> files/xc-4.3.2-gentoo.diff:
Avoid pre-stripped binaries QA warning.
diff --git a/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch b/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch
new file mode 100644
index 000000000000..545299b04186
--- /dev/null
+++ b/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch
@@ -0,0 +1,23 @@
+diff -Nru xc-4.3.2.orig/crc.c xc-4.3.2/crc.c
+--- xc-4.3.2.orig/crc.c 1996-09-27 05:47:17.000000000 +0300
++++ xc-4.3.2/crc.c 2007-04-15 14:34:09.000000000 +0300
+@@ -5,6 +5,7 @@
+ * Crc - 32 BIT ANSI X3.66 CRC checksum files
+ */
+ #include <stdio.h>
++#include <stdlib.h>
+ #define OK 0
+ #define ERROR (-1)
+ #define LINT_ARGS
+diff -Nru xc-4.3.2.orig/xcterm.c xc-4.3.2/xcterm.c
+--- xc-4.3.2.orig/xcterm.c 1996-09-25 06:58:31.000000000 +0300
++++ xc-4.3.2/xcterm.c 2007-04-15 14:33:46.000000000 +0300
+@@ -4,6 +4,8 @@
+ #define XCTERM_C 1
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
diff --git a/net-dialup/xc/xc-4.3.2-r1.ebuild b/net-dialup/xc/xc-4.3.2-r1.ebuild
index 4f579006096b..d928d1d90c5c 100644
--- a/net-dialup/xc/xc-4.3.2-r1.ebuild
+++ b/net-dialup/xc/xc-4.3.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r1.ebuild,v 1.15 2006/03/16 22:20:16 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r1.ebuild,v 1.16 2007/04/15 11:36:51 mrness Exp $
inherit eutils
@@ -20,6 +20,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-implicit-decl.patch"
# Adds 115200 bps support
epatch "${FILESDIR}/${P}-add-115200.patch"