summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-06 22:58:24 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-06 22:58:24 +0000
commite98565f3d9255b841e35508a47033698947470a0 (patch)
treed53813b19c8faaf979bb8b50b8790107ec626360 /net-dialup
parentRevision bump to drop USE="ipp" for 2.3.0 stabilization. (diff)
downloadgentoo-2-e98565f3d9255b841e35508a47033698947470a0.tar.gz
gentoo-2-e98565f3d9255b841e35508a47033698947470a0.tar.bz2
gentoo-2-e98565f3d9255b841e35508a47033698947470a0.zip
Port ebuild to EAPI4 so we can use REQUIRED_USE for frxp and threads. Bug #385575
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/freeradius/ChangeLog6
-rw-r--r--net-dialup/freeradius/freeradius-2.1.11.ebuild12
2 files changed, 12 insertions, 6 deletions
diff --git a/net-dialup/freeradius/ChangeLog b/net-dialup/freeradius/ChangeLog
index e9f20381404a..61346745c35b 100644
--- a/net-dialup/freeradius/ChangeLog
+++ b/net-dialup/freeradius/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/freeradius
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/freeradius/ChangeLog,v 1.95 2011/09/27 10:47:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/freeradius/ChangeLog,v 1.96 2011/10/06 22:58:24 hwoarang Exp $
+
+ 06 Oct 2011; Markos Chandras <hwoarang@gentoo.org> freeradius-2.1.11.ebuild:
+ Port ebuild to EAPI4 so we can use REQUIRED_USE for frxp and threads. Bug
+ #385575
*freeradius-2.1.11 (26 Sep 2011)
diff --git a/net-dialup/freeradius/freeradius-2.1.11.ebuild b/net-dialup/freeradius/freeradius-2.1.11.ebuild
index 9e8d95723248..d91e6f0602c8 100644
--- a/net-dialup/freeradius/freeradius-2.1.11.ebuild
+++ b/net-dialup/freeradius/freeradius-2.1.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/freeradius/freeradius-2.1.11.ebuild,v 1.1 2011/09/27 10:47:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/freeradius/freeradius-2.1.11.ebuild,v 1.2 2011/10/06 22:58:24 hwoarang Exp $
-EAPI="2"
+EAPI="4"
inherit eutils multilib pam autotools libtool
@@ -33,6 +33,8 @@ RDEPEND="!net-dialup/cistronradius
frxp? ( dev-lang/python )"
DEPEND="${RDEPEND}"
+REQUIRED_USE="frxp? ( threads )"
+
S="${WORKDIR}/${PN}-server-${PV}"
pkg_setup() {
@@ -51,6 +53,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-2.1.10-qafixes.patch"
epatch "${FILESDIR}/${PN}-2.1.10-pkglibdir.patch"
+ append-flags -lpthread
# kill modules we don't use
if ! use ssl; then
einfo "removing rlm_eap_{tls,ttls,ikev2,peap} modules (no use ssl)"
@@ -126,14 +129,13 @@ src_install() {
diropts
make R="${D}" install || die "make install failed"
- dosed 's:^#user *= *nobody:user = radiusd:;s:^#group *= *nobody:group = radiusd:' \
- /etc/raddb/radiusd.conf
+ sed -i -e 's:^#user *= *nobody:user = radiusd:;s:^#group *= *nobody:group = radiusd:' \
+ "${D}"/etc/raddb/radiusd.conf
chown -R root:radiusd "${D}"/etc/raddb/*
pamd_mimic_system radiusd auth account password session
mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}"
- prepalldocs
dodoc CREDITS
rm "${D}/usr/sbin/rc.radiusd"