summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-06-22 11:29:32 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-06-22 11:29:32 +0000
commit5711a7bfe741da8f7eae07dfa39e90634b111046 (patch)
tree474146a2de18b40a3e9c9463e08b1476bb74abf1 /net-im
parentFixed dependencies (Manifest recommit) (diff)
downloadgentoo-2-5711a7bfe741da8f7eae07dfa39e90634b111046.tar.gz
gentoo-2-5711a7bfe741da8f7eae07dfa39e90634b111046.tar.bz2
gentoo-2-5711a7bfe741da8f7eae07dfa39e90634b111046.zip
updates to ebuild and wrapper
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skype/ChangeLog6
-rw-r--r--net-im/skype/files/artsskype37
-rw-r--r--net-im/skype/skype-0.90.0.3.ebuild20
3 files changed, 39 insertions, 24 deletions
diff --git a/net-im/skype/ChangeLog b/net-im/skype/ChangeLog
index b05e65190598..657bffeb8ea1 100644
--- a/net-im/skype/ChangeLog
+++ b/net-im/skype/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/skype
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.1 2004/06/21 23:04:56 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.2 2004/06/22 11:29:32 humpback Exp $
+
+ 22 Jun 2004; Gustavo Felisberto <humpback@gentoo.org>;
+ skype-0.90.0.3.ebuild, files/artsskype:
+ Updated ebuild and wrapper script
*skype-0.90.0.3 (21 Jun 2004)
diff --git a/net-im/skype/files/artsskype b/net-im/skype/files/artsskype
index 023582497fbb..adb11aebe4c0 100644
--- a/net-im/skype/files/artsskype
+++ b/net-im/skype/files/artsskype
@@ -1,30 +1,35 @@
#!/bin/bash
progname="skype"
progpath="/opt/${progname}/"
-shellcheck=` which artsshell 2> /dev/null `
+shellcheck1=` which artsshell 2> /dev/null `
+shellcheck2=` which esd 2> /dev/null `
artsdcheck=` ps x | grep artsd | grep -v grep `
-if [[ -z ${shellcheck} ]]
+esdcheck=` ps x | grep esd | grep -v grep `
+
+if [[ -z ${shellcheck1} || -z ${shellcheck2} ]]
then
- echo "No installed artsshell found"
+ echo "No installed artsshell or esd found"
echo "Assuming you're running no sound daemon"
echo "Starting ${progname} without a sound wrapper"
${progpath}/${progname}.bin
else
- if [ ${shellcheck} == ${KDEDIR}/bin/artsshell ]
+ if [[ ${shellcheck1} == ${KDEDIR}/bin/artsshell && -n ${artsdcheck} ]]
then
- echo "installed artsshell found"
- echo "Checking for a running artsd"
- if [[ -n ${artsdcheck} ]]
- then
- echo "Running artsd found"
- echo "Starting artsd wrapped ${progname}"
- artsdsp ${progpath}/${progname}.bin
- else
- echo "No running artsd found"
- echo "Starting ${progname} without artsd"
- ${progpath}/${progname}.bin
- fi
+ echo "Running artsd found"
+ echo "Starting artsd wrapped ${progname}"
+ artsdsp ${progpath}/${progname}.bin
+
+ elif [[ ${shellcheck2} == /usr/bin/esd && -n ${esdcheck} ]]
+ then
+ echo "Running esd found"
+ echo "Starting esd wrapped ${progname}"
+ esddsp ${progpath}/${progname}.bin
+ else
+ echo "No running artsd or esd found"
+ echo "Starting ${progname} without sound daemon"
+ ${progpath}/${progname}.bin
fi
+
fi
exit 0
diff --git a/net-im/skype/skype-0.90.0.3.ebuild b/net-im/skype/skype-0.90.0.3.ebuild
index 869bc2a6009c..baf9fe798660 100644
--- a/net-im/skype/skype-0.90.0.3.ebuild
+++ b/net-im/skype/skype-0.90.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.90.0.3.ebuild,v 1.1 2004/06/21 23:04:56 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.90.0.3.ebuild,v 1.2 2004/06/22 11:29:32 humpback Exp $
SVER="0_90_0_3"
RESTRICT="fetch"
@@ -9,10 +9,10 @@ HOMEPAGE="http://www.${PN}.com/"
SRC_URI="
qt? ( ${PN}_ver-${SVER}.tar.bz2 )
!qt? ( ${PN}_ver-${SVER}-staticQT.tar.bz2 )"
-LICENSE="skype"
+LICENSE="skype-eula"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+IUSE="qt arts esd"
DEPEND="qt? ( >=x11-libs/qt-3.2 )
>=sys-libs/glibc-2.2.5"
S="${WORKDIR}/${PN}_ver-${SVER}"
@@ -44,12 +44,18 @@ src_unpack() {
}
src_install() {
- mv skype skype.bin
- cp ${FILESDIR}/artsskype skype
+ ## Install the wrapper script
+ if ( use arts || use esd );
+ then
+ mv skype skype.bin
+ cp ${FILESDIR}/artsskype skype
+ fi
+
dodir /opt/skype
exeopts -m0755
exeinto /opt/skype
- doexe skype skype.bin
+ doexe skype
+ use arts && doexe skype.bin
insinto /opt/skype
doins call_in.wav
dodir /usr/share/applnk/Internet
@@ -63,7 +69,7 @@ src_install() {
insinto /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
doins ${S}/icons/${SIZE}/${PN}.png
done
- fowners root:audio /opt/skype/skype.bin
+ use arts && fowners root:audio /opt/skype/skype.bin
fowners root:audio /opt/skype/skype
dodir /usr/bin/
dosym /opt/skype/skype /usr/bin/skype