summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2011-05-24 17:46:03 +0000
committerDawid Węgliński <cla@gentoo.org>2011-05-24 17:46:03 +0000
commitc5de9c1c6c18a291cc894f2b43be2401e4ebbc2f (patch)
tree86239da37212657fc551b114cdccc05bf9492fae /net-irc/miau
parentVersion bump, bug 357833, thank teidakankan AT gmail.com and Atman Sense for ... (diff)
downloadgentoo-2-c5de9c1c6c18a291cc894f2b43be2401e4ebbc2f.tar.gz
gentoo-2-c5de9c1c6c18a291cc894f2b43be2401e4ebbc2f.tar.bz2
gentoo-2-c5de9c1c6c18a291cc894f2b43be2401e4ebbc2f.zip
Version bump (bug #346105)
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/miau')
-rw-r--r--net-irc/miau/ChangeLog9
-rw-r--r--net-irc/miau/miau-0.6.6.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/net-irc/miau/ChangeLog b/net-irc/miau/ChangeLog
index d84ea7ff3eee..0eb7a5e9c8bc 100644
--- a/net-irc/miau/ChangeLog
+++ b/net-irc/miau/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/miau
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/ChangeLog,v 1.14 2007/12/13 21:34:15 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/ChangeLog,v 1.15 2011/05/24 17:46:03 cla Exp $
+
+*miau-0.6.6 (24 May 2011)
+
+ 24 May 2011; Dawid Węgliński <cla@gentoo.org> +miau-0.6.6.ebuild:
+ Version bump (bug #346105)
13 Dec 2007; Raúl Porcel <armin76@gentoo.org> -miau-0.6.4.ebuild,
miau-0.6.5.ebuild:
diff --git a/net-irc/miau/miau-0.6.6.ebuild b/net-irc/miau/miau-0.6.6.ebuild
new file mode 100644
index 000000000000..b18d5088bcf0
--- /dev/null
+++ b/net-irc/miau/miau-0.6.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/miau-0.6.6.ebuild,v 1.1 2011/05/24 17:46:03 cla Exp $
+
+inherit eutils
+
+DESCRIPTION="Persistent IRC bouncer with multi-client support - a fork of muh"
+HOMEPAGE="http://miau.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ipv6"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use ipv6; then
+ echo
+ ewarn "Enabling the ipv6 useflag will disable ipv4 entirely. Press"
+ ewarn "Ctrl+C now if you don't want this."
+ echo
+ ebeep 5
+ fi
+}
+
+src_compile() {
+ # --disable-debug seems to actually enabled it, using if use rather than
+ # use_enable to get around it.
+ if use debug; then
+ myconf="--enable-debug"
+ fi
+ econf \
+ --enable-dccbounce \
+ --enable-automode \
+ --enable-releasenick \
+ --enable-ctcp-replies \
+ --enable-mkpasswd \
+ --enable-uptime \
+ --enable-chanlog \
+ --enable-privlog \
+ --enable-onconnect \
+ --enable-empty-awaymsg \
+ $(use_enable ipv6) \
+ ${myconf} \
+ $(use_enable debug enduserdebug) \
+ $(use_enable debug pingstat) \
+ $(use_enable debug dumpstatus) \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed."
+ dodoc AUTHORS ChangeLog TODO README || die "dodoc failed."
+
+ mv "${D}/usr/share/doc/miau/examples/miaurc" \
+ "${D}/usr/share/doc/${PF}/miaurc.sample"
+ rm -rf "${D}/usr/share/doc/miau"
+}
+
+pkg_postinst() {
+ echo
+ elog "You'll need to configure miau before running it."
+ elog "Put your config in ~/.miau/miaurc"
+ elog "You can use the sample config is in /usr/share/doc/${PF}/miaurc.sample"
+ elog "For more information, see the documentation."
+ echo
+}