summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-05-15 08:31:15 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-05-15 08:31:15 +0000
commit9019ecc0a29b57e62d60deb42fc9f2c1905d0ea7 (patch)
treefa42adac5ad321b4211a9e49e83d1caf410c99b3 /net-irc
parentSort IUSE to not contain dupes. Expand tools with all the available binaries.... (diff)
downloadgentoo-2-9019ecc0a29b57e62d60deb42fc9f2c1905d0ea7.tar.gz
gentoo-2-9019ecc0a29b57e62d60deb42fc9f2c1905d0ea7.tar.bz2
gentoo-2-9019ecc0a29b57e62d60deb42fc9f2c1905d0ea7.zip
Version bumps on the 6.0 (LTS) and 7.0 branches.
(Portage version: 2.2.0_alpha105/cvs/Linux i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/atheme-services/ChangeLog9
-rw-r--r--net-irc/atheme-services/atheme-services-6.0.11.ebuild105
-rw-r--r--net-irc/atheme-services/atheme-services-7.0.2.ebuild (renamed from net-irc/atheme-services/atheme-services-7.0.0.ebuild)11
3 files changed, 115 insertions, 10 deletions
diff --git a/net-irc/atheme-services/ChangeLog b/net-irc/atheme-services/ChangeLog
index 00080bcfe9e3..d4c93d9dfc5f 100644
--- a/net-irc/atheme-services/ChangeLog
+++ b/net-irc/atheme-services/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/atheme-services
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.43 2012/05/13 06:27:44 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.44 2012/05/15 08:31:15 jdhore Exp $
+
+*atheme-services-6.0.11 (15 May 2012)
+*atheme-services-7.0.2 (15 May 2012)
+
+ 15 May 2012; Jeff Horelick <jdhore@gentoo.org> +atheme-services-6.0.11.ebuild,
+ +atheme-services-7.0.2.ebuild, -atheme-services-7.0.0.ebuild:
+ Version bumps on the 6.0 (LTS) and 7.0 branches.
13 May 2012; Jeff Horelick <jdhore@gentoo.org> atheme-services-9999.ebuild:
Make the -9999 ebuild clone the submodules too to fix the build since
diff --git a/net-irc/atheme-services/atheme-services-6.0.11.ebuild b/net-irc/atheme-services/atheme-services-6.0.11.ebuild
new file mode 100644
index 000000000000..98023fb67a85
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-6.0.11.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-6.0.11.ebuild,v 1.1 2012/05/15 08:31:15 jdhore Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic perl-module prefix
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+SRC_URI="http://atheme.net/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND="dev-libs/libmowgli:0
+ cracklib? ( sys-libs/cracklib )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-6.0.8-configure-disable.patch
+ eautoconf
+
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # QA against bundled libs
+ rm -rf libmowgli || die
+
+ # Get useful information into build.log
+ sed -i -e '/^\.SILENT:$/d' buildsys.mk.in || die
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with cracklib) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with pcre) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perlinfo
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}
diff --git a/net-irc/atheme-services/atheme-services-7.0.0.ebuild b/net-irc/atheme-services/atheme-services-7.0.2.ebuild
index 325b91255a01..ddf9b3e20735 100644
--- a/net-irc/atheme-services/atheme-services-7.0.0.ebuild
+++ b/net-irc/atheme-services/atheme-services-7.0.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-7.0.0.ebuild,v 1.2 2012/05/03 06:27:14 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-7.0.2.ebuild,v 1.1 2012/05/15 08:31:15 jdhore Exp $
EAPI=4
-inherit autotools eutils flag-o-matic perl-module
+inherit eutils flag-o-matic perl-module
DESCRIPTION="A portable and secure set of open-source and modular IRC services"
HOMEPAGE="http://atheme.net/"
@@ -42,19 +42,12 @@ pkg_setup() {
}
src_prepare() {
- # Fix broken version detection
- sed -i -e 's/2.0.0-alpha1/2.0.0/' configure.ac || die
- eautoconf
-
# fix docdir
sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
# basic logging config directive fix
sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
- # Fix a bug with compilation of the perl stuff.
- epatch "$FILESDIR"/${P}-perl-build-fix.patch
-
# QA against bundled libs
rm -rf libmowgli-2 || die
}