summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-31 21:25:20 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-31 21:25:20 +0000
commit7cce5ee9da804f34095e87d38af251eb82a6f529 (patch)
tree29a575add10730f2fee9ec36190691a9db125ad0 /net-libs/loudmouth
parentbump to r1, add patch to handle uris, bug #229745. (diff)
downloadgentoo-2-7cce5ee9da804f34095e87d38af251eb82a6f529.tar.gz
gentoo-2-7cce5ee9da804f34095e87d38af251eb82a6f529.tar.bz2
gentoo-2-7cce5ee9da804f34095e87d38af251eb82a6f529.zip
bump to 1.4.1. do not fail if keepalive doesn't work. probably fixes bug #233409.
(Portage version: 2.2_rc3/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/ChangeLog9
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.1.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 7abdbf6b568c..dc59516a006d 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/loudmouth
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.68 2008/07/24 18:17:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.69 2008/07/31 21:25:20 eva Exp $
+
+*loudmouth-1.4.1 (31 Jul 2008)
+
+ 31 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +loudmouth-1.4.1.ebuild:
+ bump to 1.4.1. do not fail if keepalive doesn't work.
+ probably fixes bug #233409.
24 Jul 2008; Raúl Porcel <armin76@gentoo.org> loudmouth-1.4.0.ebuild:
sparc/x86 stable wrt #232205
diff --git a/net-libs/loudmouth/loudmouth-1.4.1.ebuild b/net-libs/loudmouth/loudmouth-1.4.1.ebuild
new file mode 100644
index 000000000000..5e7ab302ff8d
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.1.ebuild,v 1.1 2008/07/31 21:25:20 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://www.loudmouth-project.org/"
+SRC_URI="http://ftp.imendio.com/pub/imendio/${PN}/src/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="asyncns doc ssl debug test"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1.4.0 )"
+# FIXME: can't build against system lib
+# asyncns? ( net-libs/libasyncns )"
+# openssl dropped because of bug #216705
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_with asyncns)"
+
+ if use ssl; then
+ G2CONF="${G2CONF} --with-ssl=gnutls"
+ else
+ G2CONF="${G2CONF} --with-ssl=no"
+ fi
+}