summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-06-07 09:13:53 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-06-07 09:13:53 +0000
commit3e4e03212892b4bba5c5c93c14e3f9c7373bcb1d (patch)
tree2ee8edefd00b09f3c557161512519e8b931d003f /net-mail
parentversion bump as per bug #59728. sparc keyword dropped as per bug #95319 (diff)
downloadgentoo-2-3e4e03212892b4bba5c5c93c14e3f9c7373bcb1d.tar.gz
gentoo-2-3e4e03212892b4bba5c5c93c14e3f9c7373bcb1d.tar.bz2
gentoo-2-3e4e03212892b4bba5c5c93c14e3f9c7373bcb1d.zip
fix evolution-addressbbook-export checking (2nd round) wrt bug #95291
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/lbdb/ChangeLog5
-rw-r--r--net-mail/lbdb/lbdb-0.30.ebuild13
2 files changed, 15 insertions, 3 deletions
diff --git a/net-mail/lbdb/ChangeLog b/net-mail/lbdb/ChangeLog
index 59458e62792e..488f184f3bfd 100644
--- a/net-mail/lbdb/ChangeLog
+++ b/net-mail/lbdb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/lbdb
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.21 2005/05/31 11:51:39 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.22 2005/06/07 09:13:53 ferdy Exp $
+
+ 07 Jun 2005; Fernando J. Pereda <ferdy@gentoo.org> lbdb-0.30.ebuild:
+ fix evolution-addressbbook-export checking (2nd round) wrt bug #95291
31 May 2005; Fernando J. Pereda <ferdy@gentoo.org> lbdb-0.30.ebuild:
Replace gnome with evo use flag (fixes bug #94603) and fix
diff --git a/net-mail/lbdb/lbdb-0.30.ebuild b/net-mail/lbdb/lbdb-0.30.ebuild
index c28e13f0db9c..2882aa10fa05 100644
--- a/net-mail/lbdb/lbdb-0.30.ebuild
+++ b/net-mail/lbdb/lbdb-0.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/lbdb-0.30.ebuild,v 1.4 2005/05/31 11:51:39 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/lbdb-0.30.ebuild,v 1.5 2005/06/07 09:13:53 ferdy Exp $
inherit eutils
@@ -24,7 +24,16 @@ RDEPEND="pda? ( dev-perl/p5-Palm )
ldap? ( dev-perl/perl-ldap )"
src_compile() {
- useq evo && M_PATH="/usr/libexec/evolution/2.0/:${PATH}" || M_PATH=${PATH}
+ local evoversion
+
+ if useq evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ M_PATH="/usr/libexec/evolution/${evoversion:0:3}/:${PATH}"
+ else
+ M_PATH=${PATH}
+ fi
+
PATH=${M_PATH} econf $(use_with finger) \
$(use_with abook) \
$(use_with nis ypcat) \