summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-21 04:59:43 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-21 04:59:43 +0000
commit1157adfb0092ec956526408caf26af94a5930f2f (patch)
tree006429ad027b48a0d8193a3397b38cdad340a627 /net-misc/rarpd
parentold (diff)
downloadgentoo-2-1157adfb0092ec956526408caf26af94a5930f2f.tar.gz
gentoo-2-1157adfb0092ec956526408caf26af94a5930f2f.tar.bz2
gentoo-2-1157adfb0092ec956526408caf26af94a5930f2f.zip
patch to compile against SLOT-ed libnet #17772
Diffstat (limited to 'net-misc/rarpd')
-rw-r--r--net-misc/rarpd/ChangeLog9
-rw-r--r--net-misc/rarpd/files/1.1-libnet-1.0.patch60
-rw-r--r--net-misc/rarpd/files/digest-rarpd-1.1-r11
-rw-r--r--net-misc/rarpd/rarpd-1.1-r1.ebuild34
4 files changed, 101 insertions, 3 deletions
diff --git a/net-misc/rarpd/ChangeLog b/net-misc/rarpd/ChangeLog
index d182e7aa12f1..c397b22d97d2 100644
--- a/net-misc/rarpd/ChangeLog
+++ b/net-misc/rarpd/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-misc/rarpd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rarpd/ChangeLog,v 1.5 2003/02/12 08:31:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rarpd/ChangeLog,v 1.6 2003/08/21 04:59:43 vapier Exp $
+
+*rarpd-1.1-r1 (21 Aug 2003)
+
+ 21 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Patch to compile against SLOT-ed libnet-1.0.x #17772.
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*rarpd-1.1 (28 Aug 2002)
03 Sep 2002; Maarten Thibaut <murphy@gentoo.org> rarpd-1.1.ebuild: Fixed libnet
diff --git a/net-misc/rarpd/files/1.1-libnet-1.0.patch b/net-misc/rarpd/files/1.1-libnet-1.0.patch
new file mode 100644
index 000000000000..45bacd669423
--- /dev/null
+++ b/net-misc/rarpd/files/1.1-libnet-1.0.patch
@@ -0,0 +1,60 @@
+diff -U 0 -r rarpd-1.1.orig/aclocal.m4 rarpd-1.1/aclocal.m4
+--- rarpd-1.1.orig/aclocal.m4 2003-08-19 15:55:45.204522448 -0400
++++ rarpd-1.1/aclocal.m4 2003-08-19 15:58:54.344768760 -0400
+@@ -278 +278 @@
+-if test -f "$1/libnet-config" ; then
++if test -f "$1/libnet-1.0-config" ; then
+@@ -299 +299 @@
+-if test -f "$1/libnet.h" ; then
++if test -f "$1/libnet-1.0.h" ; then
+@@ -321 +321 @@
+-LIBS="$saved_LIBS -L$1 -lnet"
++LIBS="$saved_LIBS -L$1 -lnet-1.0"
+@@ -375 +375 @@
+- if test -f "$with_libnet/libnet-config"; then
++ if test -f "$with_libnet/libnet-1.0-config"; then
+@@ -413 +413 @@
+- LIBNET_CONFIG=$ac_cv_libnet_where_cfg/libnet-config
++ LIBNET_CONFIG=$ac_cv_libnet_where_cfg/libnet-1.0-config
+diff -U 0 -r rarpd-1.1.orig/cmulocal/libnet.m4 rarpd-1.1/cmulocal/libnet.m4
+--- rarpd-1.1.orig/cmulocal/libnet.m4 2003-08-19 15:55:45.205522296 -0400
++++ rarpd-1.1/cmulocal/libnet.m4 2003-08-19 15:58:54.346768456 -0400
+@@ -7 +7 @@
+-if test -f "$1/libnet-config" ; then
++if test -f "$1/libnet-1.0-config" ; then
+@@ -28 +28 @@
+-if test -f "$1/libnet.h" ; then
++if test -f "$1/libnet-1.0.h" ; then
+@@ -50 +50 @@
+-LIBS="$saved_LIBS -L$1 -lnet"
++LIBS="$saved_LIBS -L$1 -lnet-1.0"
+@@ -104 +104 @@
+- if test -f "$with_libnet/libnet-config"; then
++ if test -f "$with_libnet/libnet-1.0-config"; then
+@@ -142 +142 @@
+- LIBNET_CONFIG=$ac_cv_libnet_where_cfg/libnet-config
++ LIBNET_CONFIG=$ac_cv_libnet_where_cfg/libnet-1.0-config
+diff -U 0 -r rarpd-1.1.orig/configure rarpd-1.1/configure
+--- rarpd-1.1.orig/configure 2003-08-19 15:55:45.205522296 -0400
++++ rarpd-1.1/configure 2003-08-19 15:58:54.370764808 -0400
+@@ -1670 +1670 @@
+- if test -f "$with_libnet/libnet-config"; then
++ if test -f "$with_libnet/libnet-1.0-config"; then
+@@ -1690 +1690 @@
+-if test -f "$i/libnet-config" ; then
++if test -f "$i/libnet-1.0-config" ; then
+@@ -1716 +1716 @@
+-LIBS="$saved_LIBS -L$i -lnet"
++LIBS="$saved_LIBS -L$i -lnet-1.0"
+@@ -1789 +1789 @@
+-if test -f "$i/libnet.h" ; then
++if test -f "$i/libnet-1.0.h" ; then
+@@ -1812 +1812 @@
+- LIBNET_CONFIG=$ac_cv_libnet_where_cfg/libnet-config
++ LIBNET_CONFIG=$ac_cv_libnet_where_cfg/libnet-1.0-config
+diff -U 0 -r rarpd-1.1.orig/rarpd.c rarpd-1.1/rarpd.c
+--- rarpd-1.1.orig/rarpd.c 2003-08-19 15:55:45.205522296 -0400
++++ rarpd-1.1/rarpd.c 2003-08-19 15:58:54.374764200 -0400
+@@ -34 +34 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
diff --git a/net-misc/rarpd/files/digest-rarpd-1.1-r1 b/net-misc/rarpd/files/digest-rarpd-1.1-r1
new file mode 100644
index 000000000000..bd90889fe960
--- /dev/null
+++ b/net-misc/rarpd/files/digest-rarpd-1.1-r1
@@ -0,0 +1 @@
+MD5 04e2ca849e758d0b88c8281775ec3b58 rarpd-1.1.tar.gz 32053
diff --git a/net-misc/rarpd/rarpd-1.1-r1.ebuild b/net-misc/rarpd/rarpd-1.1-r1.ebuild
new file mode 100644
index 000000000000..e2e2704b2d50
--- /dev/null
+++ b/net-misc/rarpd/rarpd-1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rarpd/rarpd-1.1-r1.ebuild,v 1.1 2003/08/21 04:59:43 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="reverse address resolution protocol daemon"
+HOMEPAGE="ftp://ftp.dementia.org/pub/net-tools"
+SRC_URI="ftp://ftp.dementia.org/pub/net-tools/${P}.tar.gz"
+
+DEPEND=">=net-libs/libnet-1.0.2a-r3
+ <net-libs/libnet-1.1
+ >=net-libs/libpcap-0.7.1"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ #make install DESTDIR=${D} || die # only installs rarpd to /
+ dosbin rarpd
+ doman rarpd.8
+ dodoc AUTHORS COPYING README TODO VERSION INSTALL
+}