summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-05-16 12:16:25 +0000
committerPacho Ramos <pacho@gentoo.org>2015-05-16 12:16:25 +0000
commit1e76e886d598d712a7a284055463f057b23ae9e9 (patch)
tree7c3621ad9d6e003441249f988f5695ab07197731 /net-misc/vinagre
parentppc stable wrt bug #530238 (diff)
downloadgentoo-2-1e76e886d598d712a7a284055463f057b23ae9e9.tar.gz
gentoo-2-1e76e886d598d712a7a284055463f057b23ae9e9.tar.bz2
gentoo-2-1e76e886d598d712a7a284055463f057b23ae9e9.zip
Fix building with latest freerdp (#548708 by Chris Mayo and Nick Andrade), IPV6 kernel support is needed (#518574 by Lubos Kolouch), drop old.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc/vinagre')
-rw-r--r--net-misc/vinagre/ChangeLog10
-rw-r--r--net-misc/vinagre/files/vinagre-3.14.3-freerdp2.patch35
-rw-r--r--net-misc/vinagre/vinagre-3.14.3-r1.ebuild (renamed from net-misc/vinagre/vinagre-3.12.2.ebuild)30
3 files changed, 64 insertions, 11 deletions
diff --git a/net-misc/vinagre/ChangeLog b/net-misc/vinagre/ChangeLog
index 8ee98f212d4a..82d8022acea5 100644
--- a/net-misc/vinagre/ChangeLog
+++ b/net-misc/vinagre/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/vinagre
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.115 2015/03/15 13:32:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.116 2015/05/16 12:16:25 pacho Exp $
+
+*vinagre-3.14.3-r1 (16 May 2015)
+
+ 16 May 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/vinagre-3.14.3-freerdp2.patch, +vinagre-3.14.3-r1.ebuild,
+ -vinagre-3.12.2.ebuild:
+ Fix building with latest freerdp (#548708 by Chris Mayo and Nick Andrade),
+ IPV6 kernel support is needed (#518574 by Lubos Kolouch), drop old.
15 Mar 2015; Pacho Ramos <pacho@gentoo.org> vinagre-3.14.3.ebuild:
x86 stable, bug 534012
diff --git a/net-misc/vinagre/files/vinagre-3.14.3-freerdp2.patch b/net-misc/vinagre/files/vinagre-3.14.3-freerdp2.patch
new file mode 100644
index 000000000000..5620fcd9920e
--- /dev/null
+++ b/net-misc/vinagre/files/vinagre-3.14.3-freerdp2.patch
@@ -0,0 +1,35 @@
+From c819f3e06363faa3e0c1503d7bbcf3ac88c6dedd Mon Sep 17 00:00:00 2001
+From: Nick Andrade <SDNick484@gmail.com>
+Date: Sat, 16 May 2015 08:03:29 +0100
+Subject: Fix building against newer FreeRDP versions
+
+https://bugzilla.gnome.org/show_bug.cgi?id=749124
+
+diff --git a/plugins/rdp/vinagre-rdp-tab.c b/plugins/rdp/vinagre-rdp-tab.c
+index c4c11f8..690a580 100644
+--- a/plugins/rdp/vinagre-rdp-tab.c
++++ b/plugins/rdp/vinagre-rdp-tab.c
+@@ -887,7 +887,6 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+ settings->RdpSecurity = TRUE;
+ settings->TlsSecurity = TRUE;
+ settings->NlaSecurity = TRUE;
+- settings->DisableEncryption = FALSE;
+ settings->EncryptionMethods = ENCRYPTION_METHOD_40BIT | ENCRYPTION_METHOD_128BIT | ENCRYPTION_METHOD_FIPS;
+ settings->EncryptionLevel = ENCRYPTION_LEVEL_CLIENT_COMPATIBLE;
+ #else
+@@ -898,6 +897,12 @@ open_freerdp (VinagreRdpTab *rdp_tab)
+ settings->encryption_method = ENCRYPTION_METHOD_40BIT | ENCRYPTION_METHOD_128BIT | ENCRYPTION_METHOD_FIPS;
+ settings->encryption_level = ENCRYPTION_LEVEL_CLIENT_COMPATIBLE;
+ #endif
++#include <freerdp/version.h>
++#if (FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR >= 2 && FREERDP_VERSION_REVISION >= 1)
++ settings->UseRdpSecurityLayer = FALSE;
++#else
++ settings->DisableEncryption = FALSE;
++#endif
+
+ /* Set display size */
+ #if HAVE_FREERDP_1_1
+--
+cgit v0.10.2
+
diff --git a/net-misc/vinagre/vinagre-3.12.2.ebuild b/net-misc/vinagre/vinagre-3.14.3-r1.ebuild
index ac859e3826e7..c04b6a764fda 100644
--- a/net-misc/vinagre/vinagre-3.12.2.ebuild
+++ b/net-misc/vinagre/vinagre-3.14.3-r1.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/vinagre-3.12.2.ebuild,v 1.5 2014/09/07 13:33:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/vinagre-3.14.3-r1.ebuild,v 1.1 2015/05/16 12:16:25 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
VALA_MIN_API_VERSION=0.18
-inherit gnome2 vala
+inherit gnome2 linux-info vala
DESCRIPTION="VNC client for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Vinagre"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="avahi rdp +ssh spice +telepathy"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="rdp +ssh spice +telepathy zeroconf"
# cairo used in vinagre-tab
# gdk-pixbuf used all over the place
-# FIXME: uses xfreerdp ???
RDEPEND="
>=dev-libs/glib-2.28.0:2
>=x11-libs/gtk+-3.9.6:3
@@ -27,27 +26,38 @@ RDEPEND="
>=net-libs/gtk-vnc-0.4.3[gtk3]
x11-libs/cairo:=
x11-libs/gdk-pixbuf:2
- x11-themes/gnome-icon-theme
+ x11-themes/hicolor-icon-theme
- avahi? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
rdp? ( net-misc/freerdp )
- ssh? ( >=x11-libs/vte-0.20:2.90 )
+ ssh? ( >=x11-libs/vte-0.20:2.91 )
spice? (
app-emulation/spice-protocol
>=net-misc/spice-gtk-0.5[gtk3] )
telepathy? (
dev-libs/dbus-glib
>=net-libs/telepathy-glib-0.11.6 )
+ zeroconf? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
"
DEPEND="${RDEPEND}
>=dev-lang/perl-5
+ dev-libs/appstream-glib
>=dev-util/intltool-0.50
>=sys-devel/gettext-0.17
virtual/pkgconfig
$(vala_depend)
"
+pkg_pretend() {
+ # Needed for VNC ssh tunnel, bug #518574
+ CONFIG_CHECK="~IPV6"
+ check_extra_config
+}
+
src_prepare() {
+ # Fix RDP initialization with recent FreeRDP (from 'master')
+ epatch "${FILESDIR}"/${PN}-3.14.3-freerdp.patch
+ epatch "${FILESDIR}"/${PN}-3.14.3-freerdp2.patch
+
vala_src_prepare
gnome2_src_prepare
}
@@ -55,10 +65,10 @@ src_prepare() {
src_configure() {
DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
gnome2_src_configure \
- $(use_with avahi) \
$(use_enable rdp) \
$(use_enable ssh) \
$(use_enable spice) \
$(use_with telepathy) \
+ $(use_with zeroconf avahi) \
ITSTOOL=$(type -P true)
}