summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-02-19 09:35:42 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-02-19 09:35:42 +0000
commitbaebad67504c5b7eae545a9169064f7cf6008009 (patch)
tree0e874e2f453ee24d00c919a1f2e6b011e876f28d /net-misc
parentEAPI=5 (diff)
downloadgentoo-2-baebad67504c5b7eae545a9169064f7cf6008009.tar.gz
gentoo-2-baebad67504c5b7eae545a9169064f7cf6008009.tar.bz2
gentoo-2-baebad67504c5b7eae545a9169064f7cf6008009.zip
Use python_doscript instead of python_doexe, thanks Henning Schild <henning@wh9.tu-dresden.de> in bug #540546
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/pyhoca-gui/ChangeLog10
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild35
-rw-r--r--net-misc/pyhoca-gui/pyhoca-gui-0.5.0.4-r1.ebuild (renamed from net-misc/pyhoca-gui/pyhoca-gui-0.5.0.4.ebuild)4
3 files changed, 11 insertions, 38 deletions
diff --git a/net-misc/pyhoca-gui/ChangeLog b/net-misc/pyhoca-gui/ChangeLog
index 1fab5983e361..82a6b51edf54 100644
--- a/net-misc/pyhoca-gui/ChangeLog
+++ b/net-misc/pyhoca-gui/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/pyhoca-gui
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pyhoca-gui/ChangeLog,v 1.2 2015/02/03 12:39:39 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pyhoca-gui/ChangeLog,v 1.3 2015/02/19 09:35:42 voyageur Exp $
+
+*pyhoca-gui-0.5.0.4-r1 (19 Feb 2015)
+
+ 19 Feb 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ -pyhoca-gui-0.5.0.3.ebuild, -pyhoca-gui-0.5.0.4.ebuild,
+ +pyhoca-gui-0.5.0.4-r1.ebuild:
+ Use python_doscript instead of python_doexe, thanks Henning Schild
+ <henning@wh9.tu-dresden.de> in bug #540546
*pyhoca-gui-0.5.0.4 (03 Feb 2015)
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild
deleted file mode 100644
index b5157bd90f2d..000000000000
--- a/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.3.ebuild,v 1.1 2014/11/27 14:43:07 voyageur Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
-
-DESCRIPTION="X2Go graphical client applet"
-HOMEPAGE="http://www.x2go.org"
-SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
- dev-python/pycups[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- dev-python/wxpython[${PYTHON_USEDEP}]
- >=net-misc/python-x2go-0.5.0.0[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
-
-python_install() {
- distutils-r1_python_install
- python_doexe ${PN}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- doman man/man1/*
-}
diff --git a/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.4.ebuild b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.4-r1.ebuild
index bd4fee0d41bf..c82bd953e301 100644
--- a/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.4.ebuild
+++ b/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.4.ebuild,v 1.1 2015/02/03 12:39:39 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pyhoca-gui/pyhoca-gui-0.5.0.4-r1.ebuild,v 1.1 2015/02/19 09:35:42 voyageur Exp $
EAPI=5
@@ -26,7 +26,7 @@ DEPEND="${DEPEND}
python_install() {
distutils-r1_python_install
- python_doexe ${PN}
+ python_doscript ${PN}
}
python_install_all() {