summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-08 21:27:48 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-08 21:27:48 +0000
commit8465d51eae1b58a930b1ad1438eb14c23da97753 (patch)
tree68ce39b6e4167142184985647a7ef2153f2f0366 /net-p2p
parentstable on sparc, mips (Manifest recommit) (diff)
downloadgentoo-2-8465d51eae1b58a930b1ad1438eb14c23da97753.tar.gz
gentoo-2-8465d51eae1b58a930b1ad1438eb14c23da97753.tar.bz2
gentoo-2-8465d51eae1b58a930b1ad1438eb14c23da97753.zip
Version bumped.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/Manifest2
-rw-r--r--net-p2p/bittorrent/bittorrent-3.4.ebuild61
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-3.41
4 files changed, 70 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 9c736bc13e80..46163cea0aca 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.21 2004/02/11 21:33:19 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.22 2004/03/08 21:27:48 mholzer Exp $
+
+*bittorrent-3.4 (08 Mar 2004)
+
+ 08 Mar 2004; Martin Holzer <mholzer@gentoo.org> bittorrent-3.4.ebuild:
+ Version bumped.
11 Feb 2004; Martin Holzer <mholzer@gentoo.org> bittorrent-3.3.0.ebuild:
correcting einfo. closes 36277
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index 771efe2ddb20..4aeb2a0fcd4a 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -1,5 +1,7 @@
MD5 bac8cff4b35583f5ee0f3298ff2268c6 ChangeLog 3392
+MD5 eb5127334a883ebe20431e4752ae55b0 bittorrent-3.4.ebuild 1711
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 b8435e57c0b439d46729e05a3e21de0d bittorrent-3.3.0.ebuild 1699
MD5 dfb7c0c50cc6abc6efd5cf380f4615a0 files/bittorrent-stats-3.2.1b.patch 26140
+MD5 31bd68c1e5483131e9b345cfabf3843a files/digest-bittorrent-3.4 63
MD5 5552dfd01545331cd268d47a8a18165e files/digest-bittorrent-3.3.0 66
diff --git a/net-p2p/bittorrent/bittorrent-3.4.ebuild b/net-p2p/bittorrent/bittorrent-3.4.ebuild
new file mode 100644
index 000000000000..8cf46a1b3186
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-3.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.4.ebuild,v 1.1 2004/03/08 21:27:48 mholzer Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+MY_P="${MY_P/\.0/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://bitconjurer.org/BitTorrent"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+
+DOCS="credits.txt"
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
+pkg_postinst() {
+ einfo "unofficial feature additions. If you would like statistics, please"
+ einfo "install net-p2p/bittorrent-stats."
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-3.4 b/net-p2p/bittorrent/files/digest-bittorrent-3.4
new file mode 100644
index 000000000000..3416169e3261
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-3.4
@@ -0,0 +1 @@
+MD5 3ca482259ac5d427d88379d0afa1cbe8 BitTorrent-3.4.zip 242707