summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-10-08 19:09:23 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-10-08 19:09:23 +0000
commit07ea76df41e34a425e7b2a7288baf15791e0eda8 (patch)
tree6bccba2372a7c1bc3809d5d1d221112f4dd82bf2 /net-wireless
parentversion bump thanks to dsd, bug 150496 (diff)
downloadgentoo-2-07ea76df41e34a425e7b2a7288baf15791e0eda8.tar.gz
gentoo-2-07ea76df41e34a425e7b2a7288baf15791e0eda8.tar.bz2
gentoo-2-07ea76df41e34a425e7b2a7288baf15791e0eda8.zip
Version bump. Fixes bug #149167. Should build with kernels from 2.6.16 to 2.6.18 now.
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/linux-wlan-ng-modules/ChangeLog9
-rw-r--r--net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.53
-rw-r--r--net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5.ebuild89
3 files changed, 100 insertions, 1 deletions
diff --git a/net-wireless/linux-wlan-ng-modules/ChangeLog b/net-wireless/linux-wlan-ng-modules/ChangeLog
index 8a77ec164974..c71e565088fb 100644
--- a/net-wireless/linux-wlan-ng-modules/ChangeLog
+++ b/net-wireless/linux-wlan-ng-modules/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/linux-wlan-ng-modules
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng-modules/ChangeLog,v 1.10 2006/08/26 07:51:28 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng-modules/ChangeLog,v 1.11 2006/10/08 19:09:23 betelgeuse Exp $
+
+*linux-wlan-ng-modules-0.2.5 (08 Oct 2006)
+
+ 08 Oct 2006; Petteri Räty <betelgeuse@gentoo.org>
+ +linux-wlan-ng-modules-0.2.5.ebuild:
+ Version bump. Fixes bug #149167. Should build with kernels from 2.6.16 to
+ 2.6.18 now.
26 Aug 2006; Petteri Räty <betelgeuse@gentoo.org>
+files/linux-wlan-ng-0.2.3-kernel-2.6.17.patch,
diff --git a/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.5 b/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.5
new file mode 100644
index 000000000000..f91173cb625c
--- /dev/null
+++ b/net-wireless/linux-wlan-ng-modules/files/digest-linux-wlan-ng-modules-0.2.5
@@ -0,0 +1,3 @@
+MD5 b4f6eb438533f73cd456e5ee7a3f722a linux-wlan-ng-0.2.5.tar.bz2 457056
+RMD160 3bd08380d9bd131ad960a8b3c9dd87972254357a linux-wlan-ng-0.2.5.tar.bz2 457056
+SHA256 882f5fe8c3e3a2538f59e96d002866aea1ce3ad33396da0cea7721455f4a42be linux-wlan-ng-0.2.5.tar.bz2 457056
diff --git a/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5.ebuild b/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5.ebuild
new file mode 100644
index 000000000000..6bc4da4c7650
--- /dev/null
+++ b/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.5.ebuild,v 1.1 2006/10/08 19:09:23 betelgeuse Exp $
+
+inherit eutils linux-mod
+
+MY_PN=${PN/-modules/}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Kernel modules for Prism2/2.5/3 based 802.11b USB wireless LAN products"
+HOMEPAGE="http://linux-wlan.org"
+SRC_URI="ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/${MY_P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="debug"
+
+BUILD_TARGETS="default"
+BUILD_PARAMS="WLAN_SRC=${S}/src"
+
+DEPEND="!<net-wireless/linux-wlan-ng-0.2.2"
+
+pkg_setup() {
+ # We have to put this to the global scope inside the function or it will be
+ # reset between functions because the ebuild is sourced many times.
+
+ MODULE_NAMES="p80211(net/wireless:${S}/src/p80211)"
+ MODULE_NAMES="${MODULE_NAMES} prism2_usb(net/wireless:${S}/src/prism2/driver)"
+
+ linux-mod_pkg_setup
+}
+
+config_by_usevar() {
+ local config=${3}
+ [[ -z ${config} ]] && config=${S}/default.config
+
+ if use ${2}; then
+ echo "${1}=y" >> ${config}
+ else
+ echo "${1}=n" >> ${config}
+ fi
+}
+
+src_unpack() {
+ local config=${S}/default.config
+
+ unpack ${A}
+
+ cd ${S}
+
+ cp ${S}/config.in ${config}
+
+ echo "TARGET_ROOT_ON_HOST=${D}" >> ${config}
+ echo "LINUX_SRC=${KERNEL_DIR}" >> ${config}
+ echo "FIRMWARE_DIR=/lib/firmware/" >> ${config}
+ echo "PRISM2_PCI=n" >> ${config}
+ echo "PRISM2_PLX=n" >> ${config}
+ echo "PRISM2_PCMCIA=n" >> ${config}
+ echo "PRISM2_USB=y" >> ${config}
+
+ config_by_usevar WLAN_DEBUG debug
+
+ sed -i -e "s:dep modules:modules:" ${S}/src/p80211/Makefile
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake default_config || die "emake default_config failed"
+ set_arch_to_portage
+
+ cd ${S}/src/mkmeta
+ emake || die "emake mkmeta failed"
+
+ linux-mod_src_compile
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "Support for pci, plx and pcmcia drivers has been removed in"
+ einfo "revision. For pci, plx and pcmcia drivers try for example"
+ einfo "the hostap-driver or orinoco drivers. They both work with the"
+ einfo "standard wireless tools."
+ einfo ""
+ einfo "If they do not work, please report this to betelgeuse@gentoo.org."
+}