summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-05-01 01:22:44 +0000
committerMike Frysinger <vapier@gentoo.org>2014-05-01 01:22:44 +0000
commitf950df00b4ab1b05c8c7cbb4c6d40a48fff1f55a (patch)
tree2fa53f5eb99c1232e9ff455271a9e2377fad8759 /net-wireless
parentDrop hardcoded -L/usr/lib as no system needs it and it breaks cross-compiling... (diff)
downloadgentoo-2-f950df00b4ab1b05c8c7cbb4c6d40a48fff1f55a.tar.gz
gentoo-2-f950df00b4ab1b05c8c7cbb4c6d40a48fff1f55a.tar.bz2
gentoo-2-f950df00b4ab1b05c8c7cbb4c6d40a48fff1f55a.zip
Add fix from upstream for missing -lrt linkage.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostapd/ChangeLog6
-rw-r--r--net-wireless/hostapd/files/hostapd-2.1-Fix-nt_password_hash-build.patch29
-rw-r--r--net-wireless/hostapd/hostapd-2.1-r1.ebuild3
3 files changed, 36 insertions, 2 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index 81be84528e9e..1671d6ab8c68 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/hostapd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.147 2014/05/01 01:21:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.148 2014/05/01 01:22:44 vapier Exp $
+
+ 01 May 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/hostapd-2.1-Fix-nt_password_hash-build.patch, hostapd-2.1-r1.ebuild:
+ Add fix from upstream for missing -lrt linkage.
01 May 2014; Mike Frysinger <vapier@gentoo.org> hostapd-2.0-r1.ebuild,
hostapd-2.1-r1.ebuild:
diff --git a/net-wireless/hostapd/files/hostapd-2.1-Fix-nt_password_hash-build.patch b/net-wireless/hostapd/files/hostapd-2.1-Fix-nt_password_hash-build.patch
new file mode 100644
index 000000000000..c8f745fef17d
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-2.1-Fix-nt_password_hash-build.patch
@@ -0,0 +1,29 @@
+fix from upstream git repo
+
+From 9aab81145a6ce26272b198419d288a0417e683c5 Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <j@w1.fi>
+Date: Sat, 15 Feb 2014 11:49:09 +0200
+Subject: [PATCH] Fix nt_password_hash build
+
+This needs librt on some systems for clock_gettime().
+
+Signed-off-by: Jouni Malinen <j@w1.fi>
+---
+ hostapd/Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/hostapd/Makefile b/hostapd/Makefile
+index 5fd6481..ef093e5 100644
+--- a/hostapd/Makefile
++++ b/hostapd/Makefile
+@@ -95,6 +95,7 @@ ifeq ($(CONFIG_ELOOP), eloop)
+ LIBS += -lrt
+ LIBS_c += -lrt
+ LIBS_h += -lrt
++LIBS_n += -lrt
+ endif
+
+ OBJS += ../src/utils/common.o
+--
+1.9.2
+
diff --git a/net-wireless/hostapd/hostapd-2.1-r1.ebuild b/net-wireless/hostapd/hostapd-2.1-r1.ebuild
index 0de87484b7b8..0528214cc799 100644
--- a/net-wireless/hostapd/hostapd-2.1-r1.ebuild
+++ b/net-wireless/hostapd/hostapd-2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-2.1-r1.ebuild,v 1.2 2014/05/01 01:21:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-2.1-r1.ebuild,v 1.3 2014/05/01 01:22:44 vapier Exp $
EAPI="4"
@@ -28,6 +28,7 @@ RDEPEND="${DEPEND}"
S="${S}/${PN}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-Fix-nt_password_hash-build.patch
sed -i -e "s:/etc/hostapd:/etc/hostapd/hostapd:g" \
"${S}/hostapd.conf" || die
}