summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-01-23 14:29:16 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-01-23 14:29:16 +0000
commite05d0cc7c5c64b8996f3113583b103a0f353eca7 (patch)
tree990a03a90676a16e976ebaa808da367750ac4859 /sci-astronomy/ds9
parentPass --disable-scrollkeeper in pkg_setup. (diff)
downloadgentoo-2-e05d0cc7c5c64b8996f3113583b103a0f353eca7.tar.gz
gentoo-2-e05d0cc7c5c64b8996f3113583b103a0f353eca7.tar.bz2
gentoo-2-e05d0cc7c5c64b8996f3113583b103a0f353eca7.zip
Fixed stack-smashing problems on x86 (see bug #207102).
(Portage version: 2.1.4)
Diffstat (limited to 'sci-astronomy/ds9')
-rw-r--r--sci-astronomy/ds9/ChangeLog7
-rw-r--r--sci-astronomy/ds9/ds9-5.1.ebuild7
-rw-r--r--sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch26
3 files changed, 38 insertions, 2 deletions
diff --git a/sci-astronomy/ds9/ChangeLog b/sci-astronomy/ds9/ChangeLog
index 6c68e4f98c68..1fb010bff287 100644
--- a/sci-astronomy/ds9/ChangeLog
+++ b/sci-astronomy/ds9/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/ds9
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.6 2008/01/15 16:29:36 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ChangeLog,v 1.7 2008/01/23 14:29:16 markusle Exp $
+
+ 23 Jan 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/ds9-5.1-gcc4.2-x86.patch, ds9-5.1.ebuild:
+ Fixed stack-smashing problems on x86 (see bug #207102). Thanks much
+ to hsgg <hsggebhardt@gmail.com> for his patch.
*ds9-5.1 (15 Jan 2008)
diff --git a/sci-astronomy/ds9/ds9-5.1.ebuild b/sci-astronomy/ds9/ds9-5.1.ebuild
index 9636c42ca9f8..581ea348f3a0 100644
--- a/sci-astronomy/ds9/ds9-5.1.ebuild
+++ b/sci-astronomy/ds9/ds9-5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.1.ebuild,v 1.1 2008/01/15 16:29:36 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.1.ebuild,v 1.2 2008/01/23 14:29:16 markusle Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -27,6 +27,11 @@ src_unpack() {
cd "${S}"
# patch to speed up compilation (no man pages generation)
epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ # fix stack smashing on x86 with gcc-4.2
+ if [[ "${ARCH}" == "x86" ]]; then
+ epatch "${FILESDIR}"/${P}-gcc4.2-x86.patch
+ fi
}
src_compile() {
diff --git a/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch b/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch
new file mode 100644
index 000000000000..99465caaec79
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch
@@ -0,0 +1,26 @@
+diff -Naur saods9/make.linux saods9.new/make.linux
+--- saods9/make.linux 2007-12-18 17:54:57.000000000 -0500
++++ saods9.new/make.linux 2008-01-23 08:58:46.000000000 -0500
+@@ -9,15 +9,15 @@
+
+ # note: bug with gcc 4.1 and 4.2
+ # can't use -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++CXX = g++
++CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
++CC = gcc
++CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
++
+ #CXX = g++
+-#CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
++#CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ #CC = gcc
+-#CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
+-
+-CXX = g++34
+-CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+-CC = gcc34
+-CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++#CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+
+ STRIP = strip
+ ZCAT = zcat