summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-04-05 20:42:48 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-04-05 20:42:48 +0000
commit613fdf332b319698ec6d6e94903f68c35155de68 (patch)
tree688b591d620fcc205979b16fc42407736e45d7e8 /sci-astronomy/wcslib
parentx86 stable wrt bug #404615 (diff)
downloadgentoo-2-613fdf332b319698ec6d6e94903f68c35155de68.tar.gz
gentoo-2-613fdf332b319698ec6d6e94903f68c35155de68.tar.bz2
gentoo-2-613fdf332b319698ec6d6e94903f68c35155de68.zip
Version bump
(Portage version: 2.2.0_alpha94/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/wcslib')
-rw-r--r--sci-astronomy/wcslib/ChangeLog7
-rw-r--r--sci-astronomy/wcslib/wcslib-4.13.4.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
index b682076f2ece..1d0581362b96 100644
--- a/sci-astronomy/wcslib/ChangeLog
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/wcslib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.27 2012/03/25 09:24:08 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.28 2012/04/05 20:42:48 xarthisius Exp $
+
+*wcslib-4.13.4 (05 Apr 2012)
+
+ 05 Apr 2012; Kacper Kowalik <xarthisius@gentoo.org> +wcslib-4.13.4.ebuild:
+ Version bump
*wcslib-4.13.2 (25 Mar 2012)
diff --git a/sci-astronomy/wcslib/wcslib-4.13.4.ebuild b/sci-astronomy/wcslib/wcslib-4.13.4.ebuild
new file mode 100644
index 000000000000..e24a4ce4f6af
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.13.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.13.4.ebuild,v 1.1 2012/04/05 20:42:47 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils fortran-2
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="fortran fits pgplot static-libs"
+
+RDEPEND="fortran? ( virtual/fortran )
+ fits? ( sci-libs/cfitsio )
+ pgplot? ( sci-libs/pgplot )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static) \
+ $(use_enable fortran) \
+ $(use_with fits cfitsio) \
+ $(use_with pgplot)
+}
+
+src_compile() {
+ # nasty makefile, debugging means full rewrite
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs are same as shared (compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/lib*.a
+}