summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-11-06 00:07:31 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-11-06 00:07:31 +0000
commit7fabbe407dbcdb092f21efd771901cce946d9b57 (patch)
treebf7caa64df7d8fb1f0b6e92e4f280140d0b8b4b9 /sci-astronomy
parentBug #245662 - Remove all unmaskings of the "real" USE flag. (diff)
downloadgentoo-2-7fabbe407dbcdb092f21efd771901cce946d9b57.tar.gz
gentoo-2-7fabbe407dbcdb092f21efd771901cce946d9b57.tar.bz2
gentoo-2-7fabbe407dbcdb092f21efd771901cce946d9b57.zip
Added patch to properly detect kde-3.5 header files (fixes bug #245219).
(Portage version: 2.2_rc13/cvs/Linux 2.6.27-SENTINEL-2 i686)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog6
-rw-r--r--sci-astronomy/celestia/celestia-1.5.1.ebuild6
-rw-r--r--sci-astronomy/celestia/files/celestia-1.5.1-kde-3.5.patch23
3 files changed, 33 insertions, 2 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 2f72335f2ac9..6630c86e3166 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.42 2008/10/12 11:24:55 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.43 2008/11/06 00:07:30 markusle Exp $
+
+ 05 Nov 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/celestia-1.5.1-kde-3.5.patch, celestia-1.5.1.ebuild:
+ Added patch to properly detect kde-3.5 header files (fixes bug #245219).
12 Oct 2008; Markus Dittrich <markusle@gentoo.org> celestia-1.5.1.ebuild:
Added slot dependency on kde-3.5 to make sure we don't pull in kde 4
diff --git a/sci-astronomy/celestia/celestia-1.5.1.ebuild b/sci-astronomy/celestia/celestia-1.5.1.ebuild
index d9d068c388b3..fd4a15e87fd7 100644
--- a/sci-astronomy/celestia/celestia-1.5.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.1.ebuild,v 1.2 2008/10/12 11:24:55 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.1.ebuild,v 1.3 2008/11/06 00:07:30 markusle Exp $
inherit eutils flag-o-matic gnome2 kde-functions autotools
@@ -84,6 +84,10 @@ src_unpack() {
# needed for kde GUI
epatch "${FILESDIR}"/${P}-arts.patch
+ # needed for proper detection of kde-3.5 in the presence
+ # of kde4
+ epatch "${FILESDIR}"/${P}-kde-3.5.patch
+
# remove flags to let the user decide
for cf in -O2 -ffast-math \
-fexpensive-optimizations \
diff --git a/sci-astronomy/celestia/files/celestia-1.5.1-kde-3.5.patch b/sci-astronomy/celestia/files/celestia-1.5.1-kde-3.5.patch
new file mode 100644
index 000000000000..472e78e711d6
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.5.1-kde-3.5.patch
@@ -0,0 +1,23 @@
+diff -Naur celestia-1.5.1/acinclude.m4 celestia-1.5.1.new/acinclude.m4
+--- celestia-1.5.1/acinclude.m4 2008-04-23 17:18:48.000000000 -0400
++++ celestia-1.5.1.new/acinclude.m4 2008-11-05 08:52:30.000000000 -0500
+@@ -1629,8 +1629,8 @@
+ AC_MSG_CHECKING([for KDE])
+
+ if test "${prefix}" != NONE; then
+- kde_includes=${prefix}/include
+- ac_kde_includes=$prefix/include
++ kde_includes=${prefix}/kde/3.5/include
++ ac_kde_includes=$prefix/kde/3.5/include
+
+ if test "${exec_prefix}" != NONE; then
+ kde_libraries=${libdir}
+@@ -1662,7 +1662,7 @@
+
+ if test -z "$1"; then
+
+-kde_incdirs="/usr/lib/kde/include /usr/local/kde/include /usr/local/include /usr/kde/include /usr/include/kde /usr/include /opt/kde3/include /opt/kde/include $x_includes $qt_includes"
++kde_incdirs="/usr/kde/3.5/include $x_includes $qt_includes"
+ test -n "$KDEDIR" && kde_incdirs="$KDEDIR/include $KDEDIR/include/kde $KDEDIR $kde_incdirs"
+ kde_incdirs="$ac_kde_includes $kde_incdirs"
+ AC_FIND_FILE($kde_check_header, $kde_incdirs, kde_incdir)