summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-04-15 03:30:10 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-04-15 03:30:10 +0000
commitb6f005c30dff2fe4ba4b107e00f266d2d824c8a8 (patch)
tree0d00395592bc245061e4bc45102373075f46ed63 /sci-biology/probcons
parentStable on x86 wrt bug #217599 (diff)
downloadgentoo-2-b6f005c30dff2fe4ba4b107e00f266d2d824c8a8.tar.gz
gentoo-2-b6f005c30dff2fe4ba4b107e00f266d2d824c8a8.tar.bz2
gentoo-2-b6f005c30dff2fe4ba4b107e00f266d2d824c8a8.zip
Fix build with gcc 4.3.
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'sci-biology/probcons')
-rw-r--r--sci-biology/probcons/ChangeLog8
-rw-r--r--sci-biology/probcons/files/gcc-4.3.patch44
-rw-r--r--sci-biology/probcons/probcons-1.12.ebuild5
3 files changed, 53 insertions, 4 deletions
diff --git a/sci-biology/probcons/ChangeLog b/sci-biology/probcons/ChangeLog
index aa2dd60af288..f8379e39770e 100644
--- a/sci-biology/probcons/ChangeLog
+++ b/sci-biology/probcons/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/probcons
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/ChangeLog,v 1.7 2007/10/07 02:39:03 dberkholz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/ChangeLog,v 1.8 2008/04/15 03:30:10 dberkholz Exp $
+
+ 15 Apr 2008; Donnie Berkholz <dberkholz@gentoo.org>; +files/gcc-4.3.patch,
+ probcons-1.12.ebuild:
+ Fix build with gcc 4.3.
07 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>; probcons-1.12.ebuild:
Add needed quotes; don't specify the default for DESTTREE; add die messages.
diff --git a/sci-biology/probcons/files/gcc-4.3.patch b/sci-biology/probcons/files/gcc-4.3.patch
new file mode 100644
index 000000000000..37c45c03a98f
--- /dev/null
+++ b/sci-biology/probcons/files/gcc-4.3.patch
@@ -0,0 +1,44 @@
+diff -u probcons.orig/CompareToRef.cc probcons/CompareToRef.cc
+--- probcons.orig/CompareToRef.cc 2008-04-08 16:38:46.000000000 -0700
++++ probcons/CompareToRef.cc 2008-04-08 16:39:41.000000000 -0700
+@@ -16,6 +16,7 @@
+ #include <limits>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cerrno>
+ #include <iomanip>
+
+diff -u probcons.orig/FixRef.cc probcons/FixRef.cc
+--- probcons.orig/FixRef.cc 2008-04-08 16:38:46.000000000 -0700
++++ probcons/FixRef.cc 2008-04-08 16:39:33.000000000 -0700
+@@ -17,6 +17,7 @@
+ #include <algorithm>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cerrno>
+ #include <iomanip>
+
+diff -u probcons.orig/Main.cc probcons/Main.cc
+--- probcons.orig/Main.cc 2008-04-08 16:38:46.000000000 -0700
++++ probcons/Main.cc 2008-04-08 16:39:14.000000000 -0700
+@@ -21,6 +21,7 @@
+ #include <climits>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cerrno>
+ #include <iomanip>
+
+diff -u probcons.orig/ProjectPairwise.cc probcons/ProjectPairwise.cc
+--- probcons.orig/ProjectPairwise.cc 2008-04-08 16:38:46.000000000 -0700
++++ probcons/ProjectPairwise.cc 2008-04-08 16:39:25.000000000 -0700
+@@ -16,6 +16,7 @@
+ #include <limits>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cerrno>
+ #include <iomanip>
+
diff --git a/sci-biology/probcons/probcons-1.12.ebuild b/sci-biology/probcons/probcons-1.12.ebuild
index f596a83c8176..687298923c8b 100644
--- a/sci-biology/probcons/probcons-1.12.ebuild
+++ b/sci-biology/probcons/probcons-1.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/probcons-1.12.ebuild,v 1.2 2007/10/07 02:39:03 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/probcons-1.12.ebuild,v 1.3 2008/04/15 03:30:10 dberkholz Exp $
inherit eutils toolchain-funcs
@@ -20,6 +20,7 @@ S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${P}-cxxflags.patch
+ epatch "${FILESDIR}"/gcc-4.3.patch
}
src_compile() {