summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-22 10:11:14 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-22 10:11:14 +0000
commite0a9e1799a060540106860d35f2ae85320eb231d (patch)
tree96c87744fee3dd2fb81c8099960106ed86aa8a98 /sci-libs/fftw
parentdev-haskell/wash removal (pending 01 Jan 2013), see #423763 for reference. (diff)
downloadgentoo-2-e0a9e1799a060540106860d35f2ae85320eb231d.tar.gz
gentoo-2-e0a9e1799a060540106860d35f2ae85320eb231d.tar.bz2
gentoo-2-e0a9e1799a060540106860d35f2ae85320eb231d.zip
sci-libs/fftw: Correct logic to detect openmp capabable compilers
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/ChangeLog6
-rw-r--r--sci-libs/fftw/fftw-2.1.5-r8.ebuild6
-rw-r--r--sci-libs/fftw/fftw-3.2.2-r2.ebuild6
-rw-r--r--sci-libs/fftw/fftw-3.2.2.ebuild6
-rw-r--r--sci-libs/fftw/metadata.xml26
5 files changed, 27 insertions, 23 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index 9ce73183889d..506c4c80fda8 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/fftw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.136 2013/02/19 05:13:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.137 2013/02/22 10:11:14 jlec Exp $
+
+ 22 Feb 2013; Justin Lecher <jlec@gentoo.org> fftw-2.1.5-r8.ebuild,
+ fftw-3.2.2.ebuild, fftw-3.2.2-r2.ebuild, metadata.xml:
+ Correct logic to detect openmp capabable compilers
19 Feb 2013; Christoph Junghans <ottxor@gentoo.org> metadata.xml:
fixed fma description (bug #445053)
diff --git a/sci-libs/fftw/fftw-2.1.5-r8.ebuild b/sci-libs/fftw/fftw-2.1.5-r8.ebuild
index bab7598b222e..5c9fb80fe02e 100644
--- a/sci-libs/fftw/fftw-2.1.5-r8.ebuild
+++ b/sci-libs/fftw/fftw-2.1.5-r8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r8.ebuild,v 1.14 2012/10/18 21:42:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r8.ebuild,v 1.15 2013/02/22 10:11:14 jlec Exp $
EAPI=4
@@ -32,7 +32,7 @@ pkg_setup() {
if use x86; then
is-flag "-fomit-frame-pointer" || append-flags "-fomit-frame-pointer"
fi
- if use openmp && [[ $(tc-getCC) == *gcc* ]] && ! $(tc-has-openmp); then
+ if use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
ewarn "If you want to build fftw with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"
diff --git a/sci-libs/fftw/fftw-3.2.2-r2.ebuild b/sci-libs/fftw/fftw-3.2.2-r2.ebuild
index 74909c5842bf..09bf267563fb 100644
--- a/sci-libs/fftw/fftw-3.2.2-r2.ebuild
+++ b/sci-libs/fftw/fftw-3.2.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2-r2.ebuild,v 1.3 2012/10/18 21:42:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2-r2.ebuild,v 1.4 2013/02/22 10:11:14 jlec Exp $
EAPI=2
@@ -26,7 +26,7 @@ pkg_setup() {
elif use threads; then
FFTW_THREADS="--enable-threads --disable-openmp"
fi
- if use openmp && ! tc-has-openmp; then
+ if use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
ewarn "If you want to build fftw with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"
diff --git a/sci-libs/fftw/fftw-3.2.2.ebuild b/sci-libs/fftw/fftw-3.2.2.ebuild
index 5479d4bca26d..fd45cc4fd129 100644
--- a/sci-libs/fftw/fftw-3.2.2.ebuild
+++ b/sci-libs/fftw/fftw-3.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2.ebuild,v 1.18 2012/10/18 21:42:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2.ebuild,v 1.19 2013/02/22 10:11:14 jlec Exp $
EAPI=2
@@ -26,7 +26,7 @@ pkg_setup() {
elif use threads; then
FFTW_THREADS="--enable-threads --disable-openmp"
fi
- if use openmp && ! tc-has-openmp; then
+ if use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
ewarn "If you want to build fftw with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"
diff --git a/sci-libs/fftw/metadata.xml b/sci-libs/fftw/metadata.xml
index a5d7e8bbe710..ec2aafe5eb8a 100644
--- a/sci-libs/fftw/metadata.xml
+++ b/sci-libs/fftw/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The Fastest Fourier Transform in the West is a C subroutine library
for computing the Discrete Fourier Transform (DFT) in one or more
dimensions, of both real and complex data, and of arbitrary input
@@ -11,16 +11,16 @@
that FFTW's performance is typically superior to that of other
publicly available FFT software.
</longdescription>
- <use>
- <flag name="avx">Adds support for Advanced Vector Extensions</flag>
- <flag name="float">Link default library to single precision instead of
+ <use>
+ <flag name="avx">Adds support for Advanced Vector Extensions</flag>
+ <flag name="float">Link default library to single precision instead of
double (symlinks only and fftw-2.1)</flag>
-<flag name="fma">Use the Fused Multiply Add instruction set (fma3/fma4 either one)</flag>
- <flag name="paired-single">Adds support for pair-single optimizations of mips</flag>
- <flag name="quad">Build quadruple precision lib</flag>
- <flag name="zbus">Adds support for ZBus cycle-counter of mips</flag>
- </use>
- <upstream>
- <remote-id type="freecode">fftw</remote-id>
- </upstream>
+ <flag name="fma">Use the Fused Multiply Add instruction set (fma3/fma4 either one)</flag>
+ <flag name="paired-single">Adds support for pair-single optimizations of mips</flag>
+ <flag name="quad">Build quadruple precision lib</flag>
+ <flag name="zbus">Adds support for ZBus cycle-counter of mips</flag>
+ </use>
+ <upstream>
+ <remote-id type="freecode">fftw</remote-id>
+ </upstream>
</pkgmetadata>