summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-22 18:05:24 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-22 18:05:24 +0000
commitb67e43aad6e4f956c2986f4e587dad2bab57886e (patch)
treecb62e16ae79efb803eb6a52dbf2c9c95c4ead054 /sci-libs/hdf5
parentMarked ~ppc-macos and ~x64-macos for bug #372327 (diff)
downloadgentoo-2-b67e43aad6e4f956c2986f4e587dad2bab57886e.tar.gz
gentoo-2-b67e43aad6e4f956c2986f4e587dad2bab57886e.tar.bz2
gentoo-2-b67e43aad6e4f956c2986f4e587dad2bab57886e.zip
Conditionally check for fortran support, #372557
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/ChangeLog6
-rw-r--r--sci-libs/hdf5/hdf5-1.8.4-r1.ebuild28
-rw-r--r--sci-libs/hdf5/hdf5-1.8.6.ebuild22
-rw-r--r--sci-libs/hdf5/hdf5-1.8.7.ebuild22
4 files changed, 44 insertions, 34 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 8d17f3814eb8..6741f9888b1c 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.69 2011/06/21 15:18:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.70 2011/06/22 18:05:24 jlec Exp $
+
+ 22 Jun 2011; Justin Lecher <jlec@gentoo.org> hdf5-1.8.4-r1.ebuild,
+ hdf5-1.8.6.ebuild, hdf5-1.8.7.ebuild:
+ Conditionally check for fortran support, #372557
21 Jun 2011; Justin Lecher <jlec@gentoo.org> hdf5-1.8.4-r1.ebuild,
hdf5-1.8.6.ebuild, hdf5-1.8.7.ebuild:
diff --git a/sci-libs/hdf5/hdf5-1.8.4-r1.ebuild b/sci-libs/hdf5/hdf5-1.8.4-r1.ebuild
index ab9c9360a830..10717107b159 100644
--- a/sci-libs/hdf5/hdf5-1.8.4-r1.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.4-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.4-r1.ebuild,v 1.15 2011/06/21 15:18:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.4-r1.ebuild,v 1.16 2011/06/22 18:05:24 jlec Exp $
EAPI=2
-inherit eutils fortran-2 autotools
+
+inherit autotools eutils fortran-2
DESCRIPTION="General purpose library and file format for storing scientific data"
HOMEPAGE="http://www.hdfgroup.org/HDF5/"
@@ -28,7 +29,7 @@ DEPEND="${RDEPEND}
sys-process/time"
pkg_setup() {
- fortran-2_pkg_setup
+ fortran && fortran-2_pkg_setup
if use mpi; then
if has_version 'sci-libs/hdf5[-mpi]'; then
ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
@@ -49,20 +50,21 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.8.3-as-needed.patch
- epatch "${FILESDIR}"/${PN}-1.8.3-includes.patch
- epatch "${FILESDIR}"/${PN}-1.8.3-noreturn.patch
- epatch "${FILESDIR}"/${P}-gnutools.patch
- epatch "${FILESDIR}"/${P}-scaleoffset.patch
- epatch "${FILESDIR}"/${P}-sigbus.patch
+ epatch \
+ "${FILESDIR}"/${PN}-1.8.3-as-needed.patch \
+ "${FILESDIR}"/${PN}-1.8.3-includes.patch \
+ "${FILESDIR}"/${PN}-1.8.3-noreturn.patch \
+ "${FILESDIR}"/${P}-gnutools.patch \
+ "${FILESDIR}"/${P}-scaleoffset.patch \
+ "${FILESDIR}"/${P}-sigbus.patch
# respect gentoo examples directory
- sed -i \
+ sed \
-e 's:$(docdir)/hdf5:$(DESTDIR)/$(docdir):' \
- $(find . -name Makefile.am) || die
- sed -i \
+ -i $(find . -name Makefile.am) || die
+ sed \
-e '/docdir/d' \
- config/commence.am || die
+ -i config/commence.am || die
eautoreconf
# enable shared libs by default for h5cc config utility
sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in \
diff --git a/sci-libs/hdf5/hdf5-1.8.6.ebuild b/sci-libs/hdf5/hdf5-1.8.6.ebuild
index 8bd004b51d65..da4617039069 100644
--- a/sci-libs/hdf5/hdf5-1.8.6.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.6.ebuild,v 1.4 2011/06/21 15:18:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.6.ebuild,v 1.5 2011/06/22 18:05:24 jlec Exp $
EAPI=2
@@ -27,7 +27,7 @@ DEPEND="${RDEPEND}
sys-process/time"
pkg_setup() {
- fortran-2_pkg_setup
+ fortran && fortran-2_pkg_setup
if use mpi; then
if has_version 'sci-libs/hdf5[-mpi]'; then
ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
@@ -48,17 +48,19 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.8.3-as-needed.patch
- epatch "${FILESDIR}"/${PN}-1.8.5-implicits.patch
- epatch "${FILESDIR}"/${PN}-1.8.5-noreturn.patch
- epatch "${FILESDIR}"/${PN}-1.8.4-scaleoffset.patch
+ epatch \
+ "${FILESDIR}"/${PN}-1.8.3-as-needed.patch \
+ "${FILESDIR}"/${PN}-1.8.5-implicits.patch \
+ "${FILESDIR}"/${PN}-1.8.5-noreturn.patch \
+ "${FILESDIR}"/${PN}-1.8.4-scaleoffset.patch \
# respect gentoo examples directory
- sed -i -e "s:hdf5_examples:doc/${PF}/examples:g" \
- $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
- sed -i \
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
-e '/docdir/d' \
- config/commence.am || die
+ -i config/commence.am || die
eautoreconf
# enable shared libs by default for h5cc config utility
sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in \
diff --git a/sci-libs/hdf5/hdf5-1.8.7.ebuild b/sci-libs/hdf5/hdf5-1.8.7.ebuild
index b4047eee3452..66628bec344c 100644
--- a/sci-libs/hdf5/hdf5-1.8.7.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.7.ebuild,v 1.4 2011/06/21 15:18:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.7.ebuild,v 1.5 2011/06/22 18:05:24 jlec Exp $
EAPI=2
@@ -27,7 +27,7 @@ DEPEND="${RDEPEND}
sys-process/time"
pkg_setup() {
- fortran-2_pkg_setup
+ fortran && fortran-2_pkg_setup
if use mpi; then
if has_version 'sci-libs/hdf5[-mpi]'; then
ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
@@ -44,17 +44,19 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.8.3-as-needed.patch
- epatch "${FILESDIR}"/${PN}-1.8.5-implicits.patch
- epatch "${FILESDIR}"/${PN}-1.8.5-noreturn.patch
- epatch "${FILESDIR}"/${PN}-1.8.4-scaleoffset.patch
+ epatch \
+ "${FILESDIR}"/${PN}-1.8.3-as-needed.patch \
+ "${FILESDIR}"/${PN}-1.8.5-implicits.patch \
+ "${FILESDIR}"/${PN}-1.8.5-noreturn.patch \
+ "${FILESDIR}"/${PN}-1.8.4-scaleoffset.patch \
# respect gentoo examples directory
- sed -i -e "s:hdf5_examples:doc/${PF}/examples:g" \
- $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
- sed -i \
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
-e '/docdir/d' \
- config/commence.am || die
+ -i config/commence.am || die
eautoreconf
# enable shared libs by default for h5cc config utility
sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in \