summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-11-16 03:51:31 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-11-16 03:51:31 +0000
commit3379bbe4851ab2702e3b3b5988e121b6ffaaaeb2 (patch)
treeef57e93cc0c370faec20a069e2c10e24c98f8d36 /sci-libs/libqalculate/libqalculate-0.9.0.ebuild
parentbump (diff)
downloadgentoo-2-3379bbe4851ab2702e3b3b5988e121b6ffaaaeb2.tar.gz
gentoo-2-3379bbe4851ab2702e3b3b5988e121b6ffaaaeb2.tar.bz2
gentoo-2-3379bbe4851ab2702e3b3b5988e121b6ffaaaeb2.zip
New version
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sci-libs/libqalculate/libqalculate-0.9.0.ebuild')
-rw-r--r--sci-libs/libqalculate/libqalculate-0.9.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/libqalculate-0.9.0.ebuild b/sci-libs/libqalculate/libqalculate-0.9.0.ebuild
new file mode 100644
index 000000000000..37d615dd49fd
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/libqalculate-0.9.0.ebuild,v 1.1 2005/11/16 03:51:31 ribosome Exp $
+
+DESCRIPTION="A modern multi-purpose calculator library"
+LICENSE="GPL-2"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
+
+SLOT="0"
+IUSE="nls readline"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DEPEND="dev-lang/perl
+ dev-perl/XML-Parser
+ >=dev-util/pkgconfig-0.12.0"
+
+RDEPEND=">=sci-libs/cln-1.1
+ dev-libs/libxml2
+ >=dev-libs/glib-2.4
+ >=media-gfx/gnuplot-3.7
+ net-misc/wget
+ nls? ( sys-devel/gettext )
+ readline? ( sys-libs/readline )"
+
+src_compile() {
+ # The CLN test is buggy and will often fail though an appropriate version
+ # of the library is installed.
+ CONFIG="$(use_with readline) --disable-clntest"
+ econf ${CONFIG} || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die "Installation failed."
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ dodoc ${DOCS} || die "Documentation installation failed."
+}