summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-02-25 03:03:51 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-02-25 03:03:51 +0000
commit72a8327a062618d703b212970d1a253914f9e899 (patch)
tree3166ff90720f898624af1981016a7d2f1920aa39 /sci-libs
parentCleanup metadata.xml (diff)
downloadgentoo-2-72a8327a062618d703b212970d1a253914f9e899.tar.gz
gentoo-2-72a8327a062618d703b212970d1a253914f9e899.tar.bz2
gentoo-2-72a8327a062618d703b212970d1a253914f9e899.zip
fixed multilib
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/voro++/ChangeLog5
-rw-r--r--sci-libs/voro++/voro++-0.4.6.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-libs/voro++/ChangeLog b/sci-libs/voro++/ChangeLog
index 6781801bbcc7..ce8f151c4ee2 100644
--- a/sci-libs/voro++/ChangeLog
+++ b/sci-libs/voro++/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/voro++
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/voro++/ChangeLog,v 1.1 2014/02/24 23:36:07 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/voro++/ChangeLog,v 1.2 2014/02/25 03:03:51 ottxor Exp $
+
+ 25 Feb 2014; Christoph Junghans <ottxor@gentoo.org> voro++-0.4.6.ebuild:
+ fixed multilib
*voro++-0.4.6 (24 Feb 2014)
diff --git a/sci-libs/voro++/voro++-0.4.6.ebuild b/sci-libs/voro++/voro++-0.4.6.ebuild
index 985fb3cfb575..448f5ed599aa 100644
--- a/sci-libs/voro++/voro++-0.4.6.ebuild
+++ b/sci-libs/voro++/voro++-0.4.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/voro++/voro++-0.4.6.ebuild,v 1.1 2014/02/24 23:36:07 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/voro++/voro++-0.4.6.ebuild,v 1.2 2014/02/25 03:03:51 ottxor Exp $
EAPI=5
-inherit cmake-utils
+inherit cmake-utils multilib
DESCRIPTION="A 3D Voronoi cell software library"
HOMEPAGE="http://math.lbl.gov/voro++/"
@@ -12,10 +12,15 @@ SRC_URI="${HOMEPAGE}/download/dir/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ mycmakeargs=( -DLIB=$(get_libdir) )
+ cmake-utils_src_configure
+}