summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-12 12:06:25 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-12 12:06:25 +0000
commita9c96b60af9924ded4a668ecd62ab8e43ec6cd68 (patch)
tree0e79a9474312a5c9b10f6e6766c8bae5f83c0d61 /sys-devel/gcc-apple
parentDisable broken libpng support wrt #309003. Use correct app-defaults directory. (diff)
downloadgentoo-2-a9c96b60af9924ded4a668ecd62ab8e43ec6cd68.tar.gz
gentoo-2-a9c96b60af9924ded4a668ecd62ab8e43ec6cd68.tar.bz2
gentoo-2-a9c96b60af9924ded4a668ecd62ab8e43ec6cd68.zip
Update libstdc++ version check to exclude 64-bits builds on Leopard, dtrace is 32-bits only there.
(Portage version: 2.2.00.15754-prefix/cvs/SunOS i386)
Diffstat (limited to 'sys-devel/gcc-apple')
-rw-r--r--sys-devel/gcc-apple/ChangeLog7
-rw-r--r--sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild18
-rw-r--r--sys-devel/gcc-apple/gcc-apple-4.2.1_p5647.ebuild18
3 files changed, 28 insertions, 15 deletions
diff --git a/sys-devel/gcc-apple/ChangeLog b/sys-devel/gcc-apple/ChangeLog
index 4bb5452284d9..da67cd616650 100644
--- a/sys-devel/gcc-apple/ChangeLog
+++ b/sys-devel/gcc-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc-apple
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/ChangeLog,v 1.12 2010/03/09 17:53:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/ChangeLog,v 1.13 2010/03/12 12:06:25 grobian Exp $
+
+ 12 Mar 2010; Fabian Groffen <grobian@gentoo.org>
+ gcc-apple-4.2.1_p5646.ebuild, gcc-apple-4.2.1_p5647.ebuild:
+ Update libstdc++ version check to exclude 64-bits builds on Leopard,
+ dtrace is 32-bits only there.
09 Mar 2010; Fabian Groffen <grobian@gentoo.org>
gcc-apple-4.2.1_p5566-r2.ebuild, gcc-apple-4.2.1_p5574.ebuild,
diff --git a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild
index 357204e7d851..8a0739b22060 100644
--- a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild
+++ b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild,v 1.4 2010/03/09 17:53:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5646.ebuild,v 1.5 2010/03/12 12:06:25 grobian Exp $
EAPI="3"
@@ -18,12 +18,16 @@ SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gcc-${APPLE
fortran? ( mirror://gnu/gcc/gcc-${GCC_VERS}/gcc-fortran-${GCC_VERS}.tar.bz2 )"
LICENSE="GPL-2"
-if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
- LIBSTDCXX_APPLE_VERSION=39
-else
- # pre Leopard has no dtrace, which is required by 37.11 and above
- LIBSTDCXX_APPLE_VERSION=16
-fi
+case ${CHOST} in
+ *-darwin1*|i?86-*darwin9)
+ LIBSTDCXX_APPLE_VERSION=39
+ ;;
+ *)
+ # pre Leopard has no dtrace, which is required by 37.11 and above
+ # Leopard only has 32-bits version of dtrace
+ LIBSTDCXX_APPLE_VERSION=16
+ ;;
+esac
if is_crosscompile; then
SLOT="${CTARGET}-42"
diff --git a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5647.ebuild b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5647.ebuild
index 45da26ca839c..b32519489d4c 100644
--- a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5647.ebuild
+++ b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5647.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5647.ebuild,v 1.3 2010/03/09 17:53:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5647.ebuild,v 1.4 2010/03/12 12:06:25 grobian Exp $
EAPI="3"
@@ -18,12 +18,16 @@ SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gcc-${APPLE
fortran? ( mirror://gnu/gcc/gcc-4.2.4/gcc-fortran-4.2.4.tar.bz2 )"
LICENSE="GPL-2 GPL-3"
-if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
- LIBSTDCXX_APPLE_VERSION=39
-else
- # pre Leopard has no dtrace, which is required by 37.11 and above
- LIBSTDCXX_APPLE_VERSION=16
-fi
+case ${CHOST} in
+ *-darwin1*|i?86-*darwin9)
+ LIBSTDCXX_APPLE_VERSION=39
+ ;;
+ *)
+ # pre Leopard has no dtrace, which is required by 37.11 and above
+ # Leopard only has 32-bits version of dtrace
+ LIBSTDCXX_APPLE_VERSION=16
+ ;;
+esac
if is_crosscompile; then
SLOT="${CTARGET}-42"