summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-16 19:57:14 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-16 19:57:14 +0000
commit3b4edf8cd8a66a48e9eccb30da6deb564f9e2fe0 (patch)
tree2eea0bd8b8869b62e5c1ec489accc47a83d4d852 /sys-kernel/aufs-sources
parentMark m68k/s390/sh stable. (diff)
downloadgentoo-2-3b4edf8cd8a66a48e9eccb30da6deb564f9e2fe0.tar.gz
gentoo-2-3b4edf8cd8a66a48e9eccb30da6deb564f9e2fe0.tar.bz2
gentoo-2-3b4edf8cd8a66a48e9eccb30da6deb564f9e2fe0.zip
sys-kernel/aufs-sources: Bump to latest genpatches and linux release
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-kernel/aufs-sources')
-rw-r--r--sys-kernel/aufs-sources/ChangeLog9
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.10.27.ebuild74
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.12.8.ebuild74
3 files changed, 156 insertions, 1 deletions
diff --git a/sys-kernel/aufs-sources/ChangeLog b/sys-kernel/aufs-sources/ChangeLog
index dbc885f5a2be..9ee4a681a05e 100644
--- a/sys-kernel/aufs-sources/ChangeLog
+++ b/sys-kernel/aufs-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/aufs-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.83 2014/01/14 16:49:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.84 2014/01/16 19:57:14 jlec Exp $
+
+*aufs-sources-3.12.8 (16 Jan 2014)
+*aufs-sources-3.10.27 (16 Jan 2014)
+
+ 16 Jan 2014; Justin Lecher <jlec@gentoo.org> +aufs-sources-3.10.27.ebuild,
+ +aufs-sources-3.12.8.ebuild:
+ Bump to latest genpatches and linux release
14 Jan 2014; Justin Lecher <jlec@gentoo.org> aufs-sources-3.10.26.ebuild,
aufs-sources-3.12.7.ebuild, +files/aufs-sources-3.10.26-mmap-aufs3.patch,
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.10.27.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.10.27.ebuild
new file mode 100644
index 000000000000..42b7f3772261
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.10.27.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.10.27.ebuild,v 1.1 2014/01/16 19:57:14 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="34"
+K_DEBLOB_AVAILABLE="1"
+UNIPATCH_STRICTORDER=1
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+AUFS_VERSION=3.10_p20140114
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob experimental module vanilla"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
+
+PDEPEND=">=sys-fs/aufs-util-3.9"
+
+src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST="
+ "${WORKDIR}"/aufs3-kbuild.patch
+ "${WORKDIR}"/aufs3-base.patch
+ "${WORKDIR}"/aufs3-mmap.patch"
+
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+
+ unpack ${AUFS_TARBALL}
+
+ epatch "${FILESDIR}"/${PN}-3.10.26-mmap-aufs3.patch
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util && \
+ einfo "In order to use aufs FS you need to install sys-fs/aufs-util"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.12.8.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.12.8.ebuild
new file mode 100644
index 000000000000..b0aa8a0d9001
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.12.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.12.8.ebuild,v 1.1 2014/01/16 19:57:14 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="9"
+K_DEBLOB_AVAILABLE="1"
+UNIPATCH_STRICTORDER=1
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+AUFS_VERSION=3.12_p20140114
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob experimental module vanilla"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
+
+PDEPEND=">=sys-fs/aufs-util-3.9"
+
+src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST="
+ "${WORKDIR}"/aufs3-kbuild.patch
+ "${WORKDIR}"/aufs3-base.patch
+ "${WORKDIR}"/aufs3-mmap.patch"
+
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+
+ unpack ${AUFS_TARBALL}
+
+ epatch "${FILESDIR}"/${P}-mmap-aufs3.patch
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util && \
+ einfo "In order to use aufs FS you need to install sys-fs/aufs-util"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}