summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-26 00:37:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-26 00:37:22 +0000
commit8227d9397b15213d92ec7e97abc82334a31d28ae (patch)
tree5a95192409e8843ebbc6627ae1a456a170f5a42e /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-8227d9397b15213d92ec7e97abc82334a31d28ae.tar.gz
gentoo-2-8227d9397b15213d92ec7e97abc82334a31d28ae.tar.bz2
gentoo-2-8227d9397b15213d92ec7e97abc82334a31d28ae.zip
Warn if building on top of libsupc++ since it is not well supported.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/ChangeLog5
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 3fae573a660f..3558ae891426 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.29 2013/07/24 01:44:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.30 2013/07/26 00:37:22 aballier Exp $
+
+ 26 Jul 2013; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild:
+ Warn if building on top of libsupc++ since it is not well supported.
24 Jul 2013; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild:
remove useless code from previous commit
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 7f261c9a687b..38c5fc4bf1ea 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.21 2013/07/24 01:44:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.22 2013/07/26 00:37:22 aballier Exp $
EAPI=5
@@ -35,6 +35,14 @@ DEPEND="${RDEPEND}
DOCS=( CREDITS.TXT )
+pkg_setup() {
+ if ! use libcxxrt ; then
+ ewarn "You have disabled USE=libcxxrt. This will build ${PN} against"
+ ewarn "libsupc++. Please note that this is not well supported."
+ ewarn "In particular, static linking will not work."
+ fi
+}
+
src_prepare() {
cp -f "${FILESDIR}/Makefile" lib/ || die
multilib_copy_sources