summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-10-18 09:26:46 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-10-18 09:26:46 +0000
commitc36184ef3feb52e137fa982908e8ee8b12b45763 (patch)
tree5cc8df5e49de3a436cb69d79e13274fa3df3847a /sys-process/daemontools-encore
parentVersion bump. Removed old (diff)
downloadgentoo-2-c36184ef3feb52e137fa982908e8ee8b12b45763.tar.gz
gentoo-2-c36184ef3feb52e137fa982908e8ee8b12b45763.tar.bz2
gentoo-2-c36184ef3feb52e137fa982908e8ee8b12b45763.zip
Version bump, as requested by Agostino "ago" Sarubbo in bug #469058. This release fixes problems with svc & svstat.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'sys-process/daemontools-encore')
-rw-r--r--sys-process/daemontools-encore/ChangeLog11
-rw-r--r--sys-process/daemontools-encore/daemontools-encore-1.06.ebuild51
2 files changed, 60 insertions, 2 deletions
diff --git a/sys-process/daemontools-encore/ChangeLog b/sys-process/daemontools-encore/ChangeLog
index 4b534a51b6f1..ecb37331e38e 100644
--- a/sys-process/daemontools-encore/ChangeLog
+++ b/sys-process/daemontools-encore/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/daemontools-encore
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/ChangeLog,v 1.5 2011/07/20 17:35:53 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/ChangeLog,v 1.6 2013/10/18 09:26:46 chainsaw Exp $
+
+*daemontools-encore-1.06 (18 Oct 2013)
+
+ 18 Oct 2013; Tony Vroon <chainsaw@gentoo.org>
+ +daemontools-encore-1.06.ebuild:
+ Version bump, as requested by Agostino "ago" Sarubbo in bug #469058. This
+ release fixes problems with svc & svstat.
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #118937
diff --git a/sys-process/daemontools-encore/daemontools-encore-1.06.ebuild b/sys-process/daemontools-encore/daemontools-encore-1.06.ebuild
new file mode 100644
index 000000000000..27b8aa4946d5
--- /dev/null
+++ b/sys-process/daemontools-encore/daemontools-encore-1.06.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools-encore/daemontools-encore-1.06.ebuild,v 1.1 2013/10/18 09:26:46 chainsaw Exp $
+
+EAPI=3
+
+inherit flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://untroubled.org/daemontools-encore/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+ !sys-process/daemontools
+ !app-doc/daemontools-man"
+
+src_compile() {
+ use static && append-ldflags -static
+ qmail_set_cc
+ emake || die
+}
+
+src_install() {
+ keepdir /service
+
+ echo ${D}/usr/bin >conf-bin
+ echo ${D}/usr/share/man >conf-man
+ dodir /usr/bin
+ dodir /usr/share/man
+ emake install || die
+
+ dodoc ChangeLog CHANGES CHANGES.djb README TODO
+
+ newinitd "${FILESDIR}"/svscan.init-1.02 svscan || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}