summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-21 13:41:11 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-21 13:41:11 +0000
commitcac7c162e01fabd4fb4e80fd5f96fef9b22e10a0 (patch)
treecc269ffe018db0ccab025f4b2cf6cc9d6af4b560 /www-apps
parentRemove ebuilds corresponding to Asterisk 1.8 branch which is no longer in por... (diff)
downloadgentoo-2-cac7c162e01fabd4fb4e80fd5f96fef9b22e10a0.tar.gz
gentoo-2-cac7c162e01fabd4fb4e80fd5f96fef9b22e10a0.tar.bz2
gentoo-2-cac7c162e01fabd4fb4e80fd5f96fef9b22e10a0.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/jekyll-sitemap/ChangeLog7
-rw-r--r--www-apps/jekyll-sitemap/jekyll-sitemap-0.6.1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/www-apps/jekyll-sitemap/ChangeLog b/www-apps/jekyll-sitemap/ChangeLog
index 9a58dcc2defb..73feaba3ac16 100644
--- a/www-apps/jekyll-sitemap/ChangeLog
+++ b/www-apps/jekyll-sitemap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/jekyll-sitemap
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/jekyll-sitemap/ChangeLog,v 1.2 2014/09/08 21:09:08 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/jekyll-sitemap/ChangeLog,v 1.3 2014/10/21 13:41:11 mrueg Exp $
+
+*jekyll-sitemap-0.6.1 (21 Oct 2014)
+
+ 21 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +jekyll-sitemap-0.6.1.ebuild:
+ Version bump.
*jekyll-sitemap-0.6.0 (08 Sep 2014)
diff --git a/www-apps/jekyll-sitemap/jekyll-sitemap-0.6.1.ebuild b/www-apps/jekyll-sitemap/jekyll-sitemap-0.6.1.ebuild
new file mode 100644
index 000000000000..e7dd513807ce
--- /dev/null
+++ b/www-apps/jekyll-sitemap/jekyll-sitemap-0.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/jekyll-sitemap/jekyll-sitemap-0.6.1.ebuild,v 1.1 2014/10/21 13:41:11 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Automatically generate a sitemap.xml for your Jekyll site"
+HOMEPAGE="https://github.com/jekyll/jekyll-sitemap"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=www-apps/jekyll-2 )"
+
+all_ruby_prepare() {
+ # Fix tests until rspec:3 is in the tree
+ sed -i -e "s/truthy/true/" -e "s/falsey/false/" spec/jekyll-sitemap_spec.rb || die
+}