summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-05-19 21:01:54 +0000
committerAlex Alexander <wired@gentoo.org>2011-05-19 21:01:54 +0000
commit2257fa8316b025037f91584fb7766d12f9e7d6e0 (patch)
treece4f07a33eb24de5359ed46b59a3df7471553d01 /www-client/uget
parentEAPI4 (diff)
downloadgentoo-2-2257fa8316b025037f91584fb7766d12f9e7d6e0.tar.gz
gentoo-2-2257fa8316b025037f91584fb7766d12f9e7d6e0.tar.bz2
gentoo-2-2257fa8316b025037f91584fb7766d12f9e7d6e0.zip
version bump
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'www-client/uget')
-rw-r--r--www-client/uget/ChangeLog7
-rw-r--r--www-client/uget/uget-1.7.6.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/www-client/uget/ChangeLog b/www-client/uget/ChangeLog
index c7c4626dcbf0..c40cb1d75b9d 100644
--- a/www-client/uget/ChangeLog
+++ b/www-client/uget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/uget
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.25 2011/05/19 20:53:08 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/ChangeLog,v 1.26 2011/05/19 21:01:54 wired Exp $
+
+*uget-1.7.6 (19 May 2011)
+
+ 19 May 2011; Alex Alexander <wired@gentoo.org> +uget-1.7.6.ebuild:
+ version bump
19 May 2011; Alex Alexander <wired@gentoo.org> uget-1.7.0.ebuild,
uget-1.7.3.ebuild, uget-1.7.4.ebuild, uget-9999.ebuild:
diff --git a/www-client/uget/uget-1.7.6.ebuild b/www-client/uget/uget-1.7.6.ebuild
new file mode 100644
index 000000000000..47503d5ebd7d
--- /dev/null
+++ b/www-client/uget/uget-1.7.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/uget/uget-1.7.6.ebuild,v 1.1 2011/05/19 21:01:54 wired Exp $
+
+EAPI="4"
+
+inherit base
+
+DESCRIPTION="Download manager using gtk+ and libcurl"
+HOMEPAGE="http://urlget.sourceforge.net/"
+SRC_URI="mirror://sourceforge/urlget/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aria2 +curl gstreamer hide-temp-files libnotify nls"
+
+REQUIRED_USE="|| ( aria2 curl )"
+
+RDEPEND="
+ dev-libs/libpcre
+ >=dev-libs/glib-2:2
+ >=x11-libs/gtk+-2.18:2
+ curl? ( >=net-misc/curl-7.10 )
+ gstreamer? ( media-libs/gstreamer )
+ libnotify? ( x11-libs/libnotify )
+ "
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ echo
+ ewarn "Be warned that the configuration file has been split into smaller"
+ ewarn "files in Uget >= 1.5.9 and Uget will not attempt to import your"
+ ewarn "old settings."
+ ewarn
+ ewarn "In other words, you will lose your current download lists."
+ echo
+}
+
+src_configure() {
+ econf $(use_enable nls) \
+ $(use_enable curl plugin-curl) \
+ $(use_enable aria2 plugin-aria2) \
+ $(use_enable gstreamer) \
+ $(use_enable hide-temp-files hidden) \
+ $(use_enable libnotify notify) || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # the build system forgets this :p
+ dobin uget-cmd/uget-cmd || die "uget-cmd install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use aria2; then
+ echo
+ elog "You've enabled the aria2 USE flag, so the aria2 plug-in has been"
+ elog "built. This allows you to control a local or remote instance of aria2"
+ elog "through xmlrpc. To use aria2 locally you have to emerge"
+ elog "net-misc/aria2 with the xmlrpc USE enabled manually."
+ echo
+ fi
+}