summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-01 19:19:54 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-01 19:19:54 +0000
commit515fd8f9995d5778b4d30690eaed3a909fd6aa4c (patch)
treea8f028d95be5195dbfe33034369e87f7e026bb13 /www-servers/pshs
parentUse in-source build to avoid a race. Reported by remi`. (diff)
downloadgentoo-2-515fd8f9995d5778b4d30690eaed3a909fd6aa4c.tar.gz
gentoo-2-515fd8f9995d5778b4d30690eaed3a909fd6aa4c.tar.bz2
gentoo-2-515fd8f9995d5778b4d30690eaed3a909fd6aa4c.zip
Version bump, now with QRCode printing support.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'www-servers/pshs')
-rw-r--r--www-servers/pshs/ChangeLog8
-rw-r--r--www-servers/pshs/metadata.xml1
-rw-r--r--www-servers/pshs/pshs-0.2.2.ebuild36
-rw-r--r--www-servers/pshs/pshs-9999.ebuild6
4 files changed, 48 insertions, 3 deletions
diff --git a/www-servers/pshs/ChangeLog b/www-servers/pshs/ChangeLog
index e4d98c6912fc..60d47e40991b 100644
--- a/www-servers/pshs/ChangeLog
+++ b/www-servers/pshs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/pshs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.7 2014/07/06 13:23:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.8 2014/12/01 19:19:54 mgorny Exp $
+
+*pshs-0.2.2 (01 Dec 2014)
+
+ 01 Dec 2014; Michał Górny <mgorny@gentoo.org> +pshs-0.2.2.ebuild,
+ metadata.xml, pshs-9999.ebuild:
+ Version bump, now with QRCode printing support.
06 Jul 2014; Michał Górny <mgorny@gentoo.org> pshs-0.2.1.ebuild,
pshs-9999.ebuild:
diff --git a/www-servers/pshs/metadata.xml b/www-servers/pshs/metadata.xml
index b0edd912f598..4cf7dbed58a0 100644
--- a/www-servers/pshs/metadata.xml
+++ b/www-servers/pshs/metadata.xml
@@ -10,6 +10,7 @@
using libmagic (<pkg>sys-apps/file</pkg>)</flag>
<flag name='netlink'>Use libnetlink (<pkg>sys-apps/iproute2</pkg>) to
get network interface addresses</flag>
+ <flag name='qrcode'>Enable generating QRCodes for server URL</flag>
</use>
<upstream>
<maintainer status="active">
diff --git a/www-servers/pshs/pshs-0.2.2.ebuild b/www-servers/pshs/pshs-0.2.2.ebuild
new file mode 100644
index 000000000000..c7f46fa08245
--- /dev/null
+++ b/www-servers/pshs/pshs-0.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-0.2.2.ebuild,v 1.1 2014/12/01 19:19:54 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
+HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic +netlink qrcode upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable upnp)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/www-servers/pshs/pshs-9999.ebuild b/www-servers/pshs/pshs-9999.ebuild
index 6e884522e189..283e42fba538 100644
--- a/www-servers/pshs/pshs-9999.ebuild
+++ b/www-servers/pshs/pshs-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-9999.ebuild,v 1.3 2014/07/06 13:23:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-9999.ebuild,v 1.4 2014/12/01 19:19:54 mgorny Exp $
EAPI=5
@@ -20,10 +20,11 @@ SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+magic +netlink upnp"
+IUSE="+magic +netlink qrcode upnp"
RDEPEND=">=dev-libs/libevent-2:0=
magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
upnp? ( net-libs/miniupnpc:0= )"
DEPEND="${RDEPEND}
netlink? ( sys-apps/iproute2
@@ -39,6 +40,7 @@ src_configure() {
myeconfargs=(
$(use_enable magic libmagic)
$(use_enable netlink)
+ $(use_enable qrcode qrencode)
$(use_enable upnp)
)