summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-09-23 17:14:47 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-09-23 17:14:47 +0000
commit9a65b2c895186a39c17d929ee032baf019eab3f7 (patch)
tree6672944774d386d9a64f3c9b04bc4e4f0e255c10 /x11-libs/libyui-qt
parentQA: Version bump, drop old, wrt bug #470860 (diff)
downloadgentoo-2-9a65b2c895186a39c17d929ee032baf019eab3f7.tar.gz
gentoo-2-9a65b2c895186a39c17d929ee032baf019eab3f7.tar.bz2
gentoo-2-9a65b2c895186a39c17d929ee032baf019eab3f7.zip
QA: Version bump, drop old, wrt bug #470860
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'x11-libs/libyui-qt')
-rw-r--r--x11-libs/libyui-qt/ChangeLog10
-rw-r--r--x11-libs/libyui-qt/libyui-qt-2.21.1.ebuild26
-rw-r--r--x11-libs/libyui-qt/libyui-qt-2.44.0.ebuild52
3 files changed, 60 insertions, 28 deletions
diff --git a/x11-libs/libyui-qt/ChangeLog b/x11-libs/libyui-qt/ChangeLog
index 4042f6fe2201..58efa9eb5ecd 100644
--- a/x11-libs/libyui-qt/ChangeLog
+++ b/x11-libs/libyui-qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libyui-qt
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui-qt/ChangeLog,v 1.4 2013/03/02 23:44:58 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui-qt/ChangeLog,v 1.5 2014/09/23 17:14:47 pinkbyte Exp $
+
+*libyui-qt-2.44.0 (23 Sep 2014)
+
+ 23 Sep 2014; Sergey Popov <pinkbyte@gentoo.org> -libyui-qt-2.21.1.ebuild,
+ +libyui-qt-2.44.0.ebuild:
+ QA: Version bump, drop old, wrt bug #470860
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> libyui-qt-2.21.1.ebuild:
Move Qt dependencies to the new category
diff --git a/x11-libs/libyui-qt/libyui-qt-2.21.1.ebuild b/x11-libs/libyui-qt/libyui-qt-2.21.1.ebuild
deleted file mode 100644
index b1ff4db48b52..000000000000
--- a/x11-libs/libyui-qt/libyui-qt-2.21.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui-qt/libyui-qt-2.21.1.ebuild,v 1.4 2013/03/02 23:44:58 hwoarang Exp $
-
-EAPI=4
-
-inherit cmake-utils
-
-DESCRIPTION="UI abstraction library - Qt plugin"
-HOMEPAGE="http://sourceforge.net/projects/libyui/"
-SRC_URI="mirror://sourceforge/libyui/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-qt/qtgui:4
- x11-libs/libyui
-"
-RDEPEND="${DEPEND}"
-
-src_install() {
- cmake-utils_src_install
- rm -rf "${ED}/usr/include"
-}
diff --git a/x11-libs/libyui-qt/libyui-qt-2.44.0.ebuild b/x11-libs/libyui-qt/libyui-qt-2.44.0.ebuild
new file mode 100644
index 000000000000..213b64aa5c9b
--- /dev/null
+++ b/x11-libs/libyui-qt/libyui-qt-2.44.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui-qt/libyui-qt-2.44.0.ebuild,v 1.1 2014/09/23 17:14:47 pinkbyte Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="UI abstraction library - Qt plugin"
+HOMEPAGE="https://github.com/libyui/libyui-qt"
+SRC_URI="https://github.com/libyui/${PN}/archive/${PN}/master/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-qt/qtgui:4
+ media-libs/freetype
+ x11-libs/libX11
+ x11-libs/libyui:${SLOT}
+"
+# Only Boost headers are needed
+# QtSvg headers only required, no linking
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-qt/qtsvg:4"
+
+S="${WORKDIR}/${PN}-${PN}-master-${PV}"
+
+src_prepare() {
+ cp "${EPREFIX}/usr/share/libyui/buildtools/CMakeLists.common" CMakeLists.txt || die
+
+ # TODO: set proper docs deps and USE flag for building them
+ sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+ sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_WERROR=OFF
+ -DDOC_DIR="${EPREFIX}/usr/share/doc/${P}"
+ -DRESPECT_FLAGS=ON
+ $(cmake-utils_use_enable static-libs STATIC)
+ )
+ cmake-utils_src_configure
+}