summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-04-10 06:46:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-04-10 06:46:36 +0000
commitea853305110509a5cdd8bf0b3adb08ccfc285f9b (patch)
tree0da0e18cae39a59f2ee1594f14dd81fbceb26a83 /x11-misc
parentVersion bump. (diff)
downloadgentoo-2-ea853305110509a5cdd8bf0b3adb08ccfc285f9b.tar.gz
gentoo-2-ea853305110509a5cdd8bf0b3adb08ccfc285f9b.tar.bz2
gentoo-2-ea853305110509a5cdd8bf0b3adb08ccfc285f9b.zip
rewrite
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rodent/rodent-4.6.2.ebuild35
1 files changed, 29 insertions, 6 deletions
diff --git a/x11-misc/rodent/rodent-4.6.2.ebuild b/x11-misc/rodent/rodent-4.6.2.ebuild
index 578549edca3b..d89a4155fecf 100644
--- a/x11-misc/rodent/rodent-4.6.2.ebuild
+++ b/x11-misc/rodent/rodent-4.6.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rodent/rodent-4.6.2.ebuild,v 1.1 2011/04/02 21:11:42 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rodent/rodent-4.6.2.ebuild,v 1.2 2011/04/10 06:46:36 ssuominen Exp $
EAPI=4
-inherit autotools eutils
+inherit autotools eutils fdo-mime gnome2-utils
DESCRIPTION="a fast, small and powerful file manager and graphical shell"
HOMEPAGE="http://sourceforge.net/projects/xffm/"
@@ -11,22 +11,45 @@ SRC_URI="mirror://sourceforge/project/xffm/${PV}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-libs/glib:2
dev-libs/libxml2:2
dev-libs/libzip
+ sys-apps/file
x11-libs/gtk+:2
x11-libs/libSM
x11-libs/libX11"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-util/intltool"
+ dev-util/intltool
+ dev-util/pkgconfig"
-DOCS="AUTHORS ChangeLog NEWS README TODO"
+DOCS="ChangeLog README TODO"
src_prepare() {
epatch "${FILESDIR}"/${P}-libs.patch
eautoreconf
}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}