summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-07-04 20:10:14 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-07-04 20:10:14 +0000
commit49f390db93883f608c6e423d03a7e26567a4644e (patch)
treef95234b40fee63adaaf2db39ab69275b31dedc68 /x11-plugins/wmbiff
parentFixed license, added mozilla herd to metadata (diff)
downloadgentoo-2-49f390db93883f608c6e423d03a7e26567a4644e.tar.gz
gentoo-2-49f390db93883f608c6e423d03a7e26567a4644e.tar.bz2
gentoo-2-49f390db93883f608c6e423d03a7e26567a4644e.zip
Fix mbox access, patch by Mikael Magnusson in bug #383189. Remove gnutls_certificate_verify_peers calls and LZO compression for gnutls-3 support, bug #424675
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmbiff')
-rw-r--r--x11-plugins/wmbiff/ChangeLog11
-rw-r--r--x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls-3.patch60
-rw-r--r--x11-plugins/wmbiff/files/wmbiff-0.4.27-invalid-strncpy.patch17
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.27-r1.ebuild42
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.27.ebuild4
5 files changed, 131 insertions, 3 deletions
diff --git a/x11-plugins/wmbiff/ChangeLog b/x11-plugins/wmbiff/ChangeLog
index f5c698caf91a..134f5a316b2b 100644
--- a/x11-plugins/wmbiff/ChangeLog
+++ b/x11-plugins/wmbiff/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-plugins/wmbiff
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/ChangeLog,v 1.31 2012/06/21 15:22:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/ChangeLog,v 1.32 2012/07/04 20:10:14 voyageur Exp $
+
+*wmbiff-0.4.27-r1 (04 Jul 2012)
+
+ 04 Jul 2012; Bernard Cafarelli <voyageur@gentoo.org> wmbiff-0.4.27.ebuild,
+ +wmbiff-0.4.27-r1.ebuild, +files/wmbiff-0.4.27-gnutls-3.patch,
+ +files/wmbiff-0.4.27-invalid-strncpy.patch:
+ Fix mbox access, patch by Mikael Magnusson in bug #383189. Remove
+ gnutls_certificate_verify_peers calls and LZO compression for gnutls-3
+ support, bug #424675
21 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> wmbiff-0.4.27.ebuild:
Fix sys-devel/automake >= 1.12 compability wrt #421411
diff --git a/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls-3.patch b/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls-3.patch
new file mode 100644
index 000000000000..d68512450f8e
--- /dev/null
+++ b/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls-3.patch
@@ -0,0 +1,60 @@
+diff -Naur wmbiff-0.4.27.orig/wmbiff/gnutls-common.c wmbiff-0.4.27/wmbiff/gnutls-common.c
+--- wmbiff-0.4.27.orig/wmbiff/gnutls-common.c 2012-07-04 21:45:00.013010829 +0200
++++ wmbiff-0.4.27/wmbiff/gnutls-common.c 2012-07-04 21:48:39.306250592 +0200
+@@ -4,7 +4,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <gnutls/gnutls.h>
+-#include <gnutls/extra.h>
+ #include <gnutls/x509.h>
+ #include <gnutls/openpgp.h>
+ #include <time.h>
+@@ -335,8 +334,8 @@
+ void print_cert_vrfy(gnutls_session session)
+ {
+
+- int status;
+- status = gnutls_certificate_verify_peers(session);
++ int verify_ret, status;
++ verify_ret = gnutls_certificate_verify_peers2(session, &status);
+ printf("\n");
+
+ if (status == GNUTLS_E_NO_CERTIFICATE_FOUND) {
+@@ -509,7 +508,6 @@
+
+ printf("Compression methods:");
+ printf(" ZLIB");
+- printf(", LZO");
+ printf(", NULL\n");
+ }
+
+@@ -637,8 +635,6 @@
+ comp_priority[j++] = GNUTLS_COMP_NULL;
+ if (strncasecmp(comp[i], "ZLI", 3) == 0)
+ comp_priority[j++] = GNUTLS_COMP_ZLIB;
+- if (strncasecmp(comp[i], "LZO", 3) == 0)
+- comp_priority[j++] = GNUTLS_COMP_LZO;
+ }
+ comp_priority[j] = 0;
+ }
+diff -Naur wmbiff-0.4.27.orig/wmbiff/tlsComm.c wmbiff-0.4.27/wmbiff/tlsComm.c
+--- wmbiff-0.4.27.orig/wmbiff/tlsComm.c 2012-07-04 21:45:00.013010829 +0200
++++ wmbiff-0.4.27/wmbiff/tlsComm.c 2012-07-04 21:50:27.897367863 +0200
+@@ -410,7 +410,7 @@
+ tls_check_certificate(struct connection_state *scs,
+ const char *remote_hostname)
+ {
+- int certstat;
++ int verify_ret, certstat;
+ const gnutls_datum *cert_list;
+ int cert_list_size = 0;
+ gnutls_x509_crt cert;
+@@ -419,7 +419,7 @@
+ bad_certificate(scs, "Unable to get certificate from peer.\n");
+ return; /* bad_cert will exit if -skip-certificate-check was not given */
+ }
+- certstat = gnutls_certificate_verify_peers(scs->tls_state);
++ verify_ret = gnutls_certificate_verify_peers2(scs->tls_state, &certstat);
+ if (certstat == GNUTLS_E_NO_CERTIFICATE_FOUND) {
+ bad_certificate(scs, "server presented no certificate.\n");
+ #ifdef GNUTLS_CERT_CORRUPTED
diff --git a/x11-plugins/wmbiff/files/wmbiff-0.4.27-invalid-strncpy.patch b/x11-plugins/wmbiff/files/wmbiff-0.4.27-invalid-strncpy.patch
new file mode 100644
index 000000000000..07f9bad989d6
--- /dev/null
+++ b/x11-plugins/wmbiff/files/wmbiff-0.4.27-invalid-strncpy.patch
@@ -0,0 +1,17 @@
+This corrupted the path for me before, so it couldn't find the file. Presumably since the glibc change to copy stuff backwards.
+
+diff -pudr wmbiff-0.4.27/wmbiff/mboxClient.c wmbiff-0.4.27-mik/wmbiff/mboxClient.c
+--- wmbiff-0.4.27/wmbiff/mboxClient.c 2004-03-28 01:28:58.000000000 +0100
++++ wmbiff-0.4.27-mik/wmbiff/mboxClient.c 2011-09-16 09:54:22.834144487 +0200
+@@ -149,7 +149,10 @@ int mboxCreate(Pop3 pc, const char *str)
+ DM(pc, DEBUG_ERROR, "mbox '%s' is too long.\n", str + 5);
+ memset(pc->path, 0, BUF_BIG);
+ } else {
+- strncpy(pc->path, str + 5, BUF_BIG - 1); /* cut off ``mbox:'' */
++ /* str is always pc.path, so we can't use strncpy */
++ int len = strlen(str + 5);
++ memmove(pc->path, str + 5, min(len, BUF_BIG - 1)); /* cut off ``mbox:'' */
++ pc->path[len] = '\0';
+ }
+ }
+
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.27-r1.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.27-r1.ebuild
new file mode 100644
index 000000000000..4ddbc8bcd9d5
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.27-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.27-r1.ebuild,v 1.1 2012/07/04 20:10:14 voyageur Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes."
+HOMEPAGE="http://sourceforge.net/projects/wmbiff/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crypt"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1
+ >=net-libs/gnutls-1.2.3
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="ChangeLog FAQ NEWS README README.licq TODO wmbiff/sample.wmbiffrc"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gnutls.patch
+ epatch "${FILESDIR}"/${P}-gnutls-3.patch
+ epatch "${FILESDIR}"/${P}-invalid-strncpy.patch
+ sed -i -e '/AC_PATH_XTRA_CORRECTED/d' configure.ac || die
+ sed -i -e '/pkg.*SCRIPTS/s:pkglib:pkgdata:' scripts/Makefile.am || die #421411
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable crypt crypto)
+}
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
index efcfaaa52aba..6de616dd9926 100644
--- a/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
+++ b/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild,v 1.11 2012/06/21 15:23:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild,v 1.12 2012/07/04 20:10:14 voyageur Exp $
EAPI=4
inherit autotools eutils
@@ -19,7 +19,7 @@ RDEPEND="x11-libs/libX11
x11-libs/libXpm
crypt? (
>=dev-libs/libgcrypt-1.2.1
- >=net-libs/gnutls-1.2.3
+ <net-libs/gnutls-3.0
)"
DEPEND="${RDEPEND}
virtual/pkgconfig