summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-03-19 20:21:33 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-03-19 20:21:33 +0000
commit03d7f4514a9fd31b176d1f591672490c5429de0d (patch)
treef3aaaab75ea2a55d8d31bc49d70e83fdea70d725 /x11-plugins/wmudmount
parentMove sys-apps/kmod before sys-apps/module-init-tools in the RDEPEND wrt #408911 (diff)
downloadgentoo-2-03d7f4514a9fd31b176d1f591672490c5429de0d.tar.gz
gentoo-2-03d7f4514a9fd31b176d1f591672490c5429de0d.tar.bz2
gentoo-2-03d7f4514a9fd31b176d1f591672490c5429de0d.zip
And version bump, spotted by ssuominen
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmudmount')
-rw-r--r--x11-plugins/wmudmount/ChangeLog7
-rw-r--r--x11-plugins/wmudmount/wmudmount-1.11.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-plugins/wmudmount/ChangeLog b/x11-plugins/wmudmount/ChangeLog
index d59e8505fd0b..f0f604338568 100644
--- a/x11-plugins/wmudmount/ChangeLog
+++ b/x11-plugins/wmudmount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmudmount
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.6 2012/03/19 20:11:21 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.7 2012/03/19 20:21:33 voyageur Exp $
+
+*wmudmount-1.11 (19 Mar 2012)
+
+ 19 Mar 2012; Bernard Cafarelli <voyageur@gentoo.org> +wmudmount-1.11.ebuild:
+ And version bump, spotted by ssuominen
19 Mar 2012; Bernard Cafarelli <voyageur@gentoo.org> wmudmount-1.8.ebuild:
Requires convert at build time, thanks Piotr Szymaniak in bug #408649
diff --git a/x11-plugins/wmudmount/wmudmount-1.11.ebuild b/x11-plugins/wmudmount/wmudmount-1.11.ebuild
new file mode 100644
index 000000000000..efc53a9a9992
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-1.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/wmudmount-1.11.ebuild,v 1.1 2012/03/19 20:21:33 voyageur Exp $
+
+EAPI=4
+inherit flag-o-matic gnome2-utils
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="http://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+RDEPEND=">=x11-libs/gtk+-2.18:2
+ dev-libs/dbus-glib
+ sys-fs/udisks
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}