summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-06-10 18:55:30 +0000
committerPacho Ramos <pacho@gentoo.org>2013-06-10 18:55:30 +0000
commite48ff45de03043eb1c85fa58da9e45e3cc362d94 (patch)
tree24c0bb993882c8e4f28c65737e27ba53c97f6792 /x11-terms
parentVersion bump. (diff)
downloadgentoo-2-e48ff45de03043eb1c85fa58da9e45e3cc362d94.tar.gz
gentoo-2-e48ff45de03043eb1c85fa58da9e45e3cc362d94.tar.bz2
gentoo-2-e48ff45de03043eb1c85fa58da9e45e3cc362d94.zip
Version bump, drop old
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/ChangeLog7
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.8.3.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/x11-terms/gnome-terminal/ChangeLog b/x11-terms/gnome-terminal/ChangeLog
index 274209f8af05..8bf7b1e31858 100644
--- a/x11-terms/gnome-terminal/ChangeLog
+++ b/x11-terms/gnome-terminal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/gnome-terminal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.272 2013/05/18 19:42:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.273 2013/06/10 18:55:30 pacho Exp $
+
+*gnome-terminal-3.8.3 (10 Jun 2013)
+
+ 10 Jun 2013; Pacho Ramos <pacho@gentoo.org> +gnome-terminal-3.8.3.ebuild:
+ Version bump, drop old
18 May 2013; Pacho Ramos <pacho@gentoo.org> -gnome-terminal-3.8.1.ebuild,
gnome-terminal-3.8.2.ebuild:
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.8.3.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.8.3.ebuild
new file mode 100644
index 000000000000..987674614ada
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.8.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-3.8.3.ebuild,v 1.1 2013/06/10 18:55:30 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://help.gnome.org/users/gnome-terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+nautilus"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X]
+RDEPEND="
+ >=dev-libs/glib-2.33.2:2
+ >=x11-libs/gtk+-3.6:3[X]
+ >=x11-libs/vte-0.34.6:2.90
+ >=gnome-base/gconf-2.31.3
+ >=gnome-base/dconf-0.12
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ x11-libs/libSM
+ x11-libs/libICE
+ nautilus? ( >=gnome-base/nautilus-3 )
+"
+# gtk+:2 needed for gtk-builder-convert, bug 356239
+DEPEND="${RDEPEND}
+ || ( dev-util/gtk-builder-convert <=x11-libs/gtk+-2.24.10:2 )
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40
+ >=gnome-base/dconf-0.14.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened
+ tab you will need to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte.sh"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS"
+ # FIXME: leave smclient configure unset until it accepts values from the
+ # switch and not from GDK_TARGET, bug #363033
+ gnome2_src_configure \
+ --disable-static \
+ --enable-migration \
+ $(use_with nautilus nautilus-extension)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if [[ ${REPLACING_VERSIONS} < 3.6.1-r1 && ${REPLACING_VERSIONS} != 2.32.1-r1 &&
+ ${REPLACING_VERSIONS} != 3.4.1.1-r1 ]]; then
+ elog
+ elog "Gnome Terminal no longer uses login shell by default, switching"
+ elog "to upstream default. Because of this, if you have some command you"
+ elog "want to be run, be sure to have it placed in your ~/.bashrc file."
+ elog
+ fi
+ readme.gentoo_print_elog
+}