summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-22 17:04:45 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-22 17:04:45 +0000
commitb989fdeea63ea3116ea6cbac95353e8afa1e26d0 (patch)
tree58d0f3f916ebb1e3b5c5568deb5b54f9434468c3 /xfce-base
parentamd64 stable, bug 319265 (diff)
downloadgentoo-2-b989fdeea63ea3116ea6cbac95353e8afa1e26d0.tar.gz
gentoo-2-b989fdeea63ea3116ea6cbac95353e8afa1e26d0.tar.bz2
gentoo-2-b989fdeea63ea3116ea6cbac95353e8afa1e26d0.zip
Versoin bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-session/ChangeLog8
-rw-r--r--xfce-base/xfce4-session/xfce4-session-4.6.2.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/xfce-base/xfce4-session/ChangeLog b/xfce-base/xfce4-session/ChangeLog
index 10201444f5f1..308e7bb13472 100644
--- a/xfce-base/xfce4-session/ChangeLog
+++ b/xfce-base/xfce4-session/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce4-session
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/ChangeLog,v 1.108 2010/04/14 17:42:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/ChangeLog,v 1.109 2010/05/22 17:04:45 angelos Exp $
+
+*xfce4-session-4.6.2 (22 May 2010)
+
+ 22 May 2010; Christoph Mende <angelos@gentoo.org>
+ +xfce4-session-4.6.2.ebuild:
+ Version bump
14 Apr 2010; Jeroen Roovers <jer@gentoo.org>
xfce4-session-4.6.1-r1.ebuild:
diff --git a/xfce-base/xfce4-session/xfce4-session-4.6.2.ebuild b/xfce-base/xfce4-session/xfce4-session-4.6.2.ebuild
new file mode 100644
index 000000000000..23bc2fd8d377
--- /dev/null
+++ b/xfce-base/xfce4-session/xfce4-session-4.6.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/xfce4-session-4.6.2.ebuild,v 1.1 2010/05/22 17:04:45 angelos Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Session manager for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-session/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug fortune gnome gnome-keyring profile"
+
+RDEPEND="gnome-base/libglade
+ >=dev-libs/dbus-glib-0.73
+ x11-libs/libX11
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.12
+ x11-apps/iceauth
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
+ >=xfce-base/xfce-utils-4.6
+ gnome? ( gnome-base/gconf )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ fortune? ( games-misc/fortune-mod )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ --disable-static
+ $(use_enable gnome)
+ $(use_enable gnome-keyring libgnome-keyring)
+ $(use_enable debug)
+ $(use_enable profile profiling)
+ $(use_enable profile gcov)"
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+}
+
+src_install() {
+ xfconf_src_install
+
+ if ! use fortune; then
+ # Wipe away unusable xfce4-tips
+ rm -Rf "${D}"/usr/share/xfce4/tips
+ rm -f "${D}"/usr/bin/xfce4-tips \
+ "${D}"/usr/lib/debug/usr/bin/xfce4-tips.debug \
+ "${D}"/etc/xdg/autostart/xfce4-tips-autostart.desktop
+ rmdir -p "${D}"/etc/xdg/autostart
+ fi
+}