summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Authen-SASL/Authen-SASL-2.04.ebuild9
-rw-r--r--dev-perl/Digest-MD5/Digest-MD5-2.33.ebuild13
-rw-r--r--dev-perl/TermReadKey/TermReadKey-2.21.ebuild10
-rw-r--r--dev-perl/digest-base/digest-base-1.05.ebuild9
-rw-r--r--dev-perl/perl-ldap/perl-ldap-0.31.ebuild21
-rw-r--r--net-irc/bnc/bnc-2.6.2.ebuild36
-rw-r--r--net-irc/bnc/bnc-2.6.4.ebuild11
-rw-r--r--net-irc/bnc/bnc-2.8.4.ebuild36
-rw-r--r--net-irc/bnc/bnc-2.8.6.ebuild6
-rw-r--r--net-irc/bnc/files/digest-bnc-2.6.21
-rw-r--r--net-irc/bnc/files/digest-bnc-2.8.41
11 files changed, 39 insertions, 114 deletions
diff --git a/dev-perl/Authen-SASL/Authen-SASL-2.04.ebuild b/dev-perl/Authen-SASL/Authen-SASL-2.04.ebuild
index 6b8095cbc4c6..9177de5658e9 100644
--- a/dev-perl/Authen-SASL/Authen-SASL-2.04.ebuild
+++ b/dev-perl/Authen-SASL/Authen-SASL-2.04.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Authen-SASL/Authen-SASL-2.04.ebuild,v 1.11 2004/05/12 05:01:45 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Authen-SASL/Authen-SASL-2.04.ebuild,v 1.12 2004/05/28 02:53:18 vapier Exp $
inherit perl-module
-S=${WORKDIR}/${P}
DESCRIPTION="A Perl SASL interface"
-AUTHOR="GBARR"
HOMEPAGE="http://search.cpan.org/CPAN/authors/id/${AUTHOR:0:1}/${AUTHOR:0:2}/${AUTHOR}/"
SRC_URI="${HOMEPAGE}/${P}.tar.gz"
-SLOT="0"
LICENSE="Artistic"
-KEYWORDS="x86 sparc alpha ppc ia64 mips amd64 s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm amd64 ia64 s390"
export OPTIMIZE="$CFLAGS"
+AUTHOR="GBARR"
diff --git a/dev-perl/Digest-MD5/Digest-MD5-2.33.ebuild b/dev-perl/Digest-MD5/Digest-MD5-2.33.ebuild
index 639aba1ac579..9546d6ceb101 100644
--- a/dev-perl/Digest-MD5/Digest-MD5-2.33.ebuild
+++ b/dev-perl/Digest-MD5/Digest-MD5-2.33.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Digest-MD5/Digest-MD5-2.33.ebuild,v 1.9 2004/05/12 04:59:39 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Digest-MD5/Digest-MD5-2.33.ebuild,v 1.10 2004/05/28 02:52:37 vapier Exp $
inherit perl-module
-S=${WORKDIR}/${P}
DESCRIPTION="MD5 message digest algorithm"
-SRC_URI="http://www.cpan.org/modules/by-authors/id/G/GA/GAAS/${P}.tar.gz"
HOMEPAGE="http://http://www.cpan.org/modules/by-authors/id/G/GA/GAAS/${P}.readme"
+SRC_URI="http://www.cpan.org/modules/by-authors/id/G/GA/GAAS/${P}.tar.gz"
-SLOT="0"
LICENSE="Artistic | GPL-2"
-KEYWORDS="x86 amd64 ppc sparc alpha hppa ia64 mips s390"
-
-mydoc="rfc*.txt"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390"
DEPEND="dev-perl/digest-base"
+
+mydoc="rfc*.txt"
diff --git a/dev-perl/TermReadKey/TermReadKey-2.21.ebuild b/dev-perl/TermReadKey/TermReadKey-2.21.ebuild
index 11cf3ea1d82f..feb2e1d6eb4b 100644
--- a/dev-perl/TermReadKey/TermReadKey-2.21.ebuild
+++ b/dev-perl/TermReadKey/TermReadKey-2.21.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/TermReadKey/TermReadKey-2.21.ebuild,v 1.6 2004/03/14 20:10:54 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/TermReadKey/TermReadKey-2.21.ebuild,v 1.7 2004/05/28 02:54:54 vapier Exp $
inherit perl-module
-S=${WORKDIR}/${P}
-DESCRIPTION="Change terminal modes, and perform non-blocking reads."
+DESCRIPTION="Change terminal modes, and perform non-blocking reads"
HOMEPAGE="http://cpan.valueclick.com/authors/id/J/JS/JSTOWE/${P}.readme"
SRC_URI="http://cpan.valueclick.com/authors/id/J/JS/JSTOWE/${P}.tar.gz"
-SLOT="0"
LICENSE="Artistic"
-KEYWORDS="x86 amd64 ppc sparc alpha hppa ia64 mips ppc64"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64"
+IUSE=""
mymake="/usr"
diff --git a/dev-perl/digest-base/digest-base-1.05.ebuild b/dev-perl/digest-base/digest-base-1.05.ebuild
index 9e95be197d94..df2f61459074 100644
--- a/dev-perl/digest-base/digest-base-1.05.ebuild
+++ b/dev-perl/digest-base/digest-base-1.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/digest-base/digest-base-1.05.ebuild,v 1.11 2004/05/12 04:58:38 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/digest-base/digest-base-1.05.ebuild,v 1.12 2004/05/28 02:52:35 vapier Exp $
inherit perl-module
@@ -8,12 +8,11 @@ MY_P=Digest-${PV}
S=${WORKDIR}/${MY_P}
DESCRIPTION="MD5 message digest algorithm"
-SRC_URI="http://www.cpan.org/modules/by-authors/id/G/GA/GAAS/${MY_P}.tar.gz"
HOMEPAGE="http://http://www.cpan.org/modules/by-authors/id/G/GA/GAAS/${MY_P}.readme"
+SRC_URI="http://www.cpan.org/modules/by-authors/id/G/GA/GAAS/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="Artistic | GPL-2"
-KEYWORDS="x86 amd64 ppc sparc alpha hppa ia64 mips s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390"
mydoc="rfc*.txt"
-
diff --git a/dev-perl/perl-ldap/perl-ldap-0.31.ebuild b/dev-perl/perl-ldap/perl-ldap-0.31.ebuild
index 50d1f7e50616..214c907115ec 100644
--- a/dev-perl/perl-ldap/perl-ldap-0.31.ebuild
+++ b/dev-perl/perl-ldap/perl-ldap-0.31.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-ldap/perl-ldap-0.31.ebuild,v 1.5 2004/05/12 05:02:55 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-ldap/perl-ldap-0.31.ebuild,v 1.6 2004/05/28 02:55:12 vapier Exp $
inherit perl-module
DESCRIPTION="A collection of perl modules which provide an object-oriented interface to LDAP servers."
-SRC_URI="http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/${P}.tar.gz"
HOMEPAGE="http://search.cpan.org/~gbarr/${P}/"
-IUSE="sasl xml ssl"
-SLOT="0"
+SRC_URI="http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/${P}.tar.gz"
+
LICENSE="Artistic"
-KEYWORDS="x86 alpha sparc ~ppc ia64 mips s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm ia64 s390"
+IUSE="sasl xml ssl"
-DEPEND="${DEPEND} dev-perl/Convert-ASN1
- dev-perl/URI
- sasl? ( dev-perl/Digest-MD5 dev-perl/Authen-SASL )
- xml? ( dev-perl/XML-Parser )
- ssl? ( >=dev-perl/IO-Socket-SSL-0.81 )"
+DEPEND="dev-perl/Convert-ASN1
+ dev-perl/URI
+ sasl? ( dev-perl/Digest-MD5 dev-perl/Authen-SASL )
+ xml? ( dev-perl/XML-Parser )
+ ssl? ( >=dev-perl/IO-Socket-SSL-0.81 )"
diff --git a/net-irc/bnc/bnc-2.6.2.ebuild b/net-irc/bnc/bnc-2.6.2.ebuild
deleted file mode 100644
index 8e0420f2fd6d..000000000000
--- a/net-irc/bnc/bnc-2.6.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.6.2.ebuild,v 1.8 2003/12/29 18:52:20 vapier Exp $
-
-MY_P=${P/-/}
-DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
-HOMEPAGE="http://gotbnc.com/"
-SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz
- http://bnc.ircadmin.net/${MY_P}.tar.gz
- ftp://ftp.ircadmin.net/bnc/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
-
-DEPEND="virtual/glibc"
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- econf || die
- emake || die
- mv mkpasswd bncmkpasswd
-}
-
-src_install() {
- dodoc CHANGES COPYING README
- dobin bnc bncchk bncsetup bncmkpasswd
- insinto /usr/share/${MY_P}
- doins example.conf motd
-}
-
-pkg_postinst() {
- einfo "You can find an example motd/conf file here:"
- einfo " /usr/share/${MY_P}/{example.conf,motd}"
-}
diff --git a/net-irc/bnc/bnc-2.6.4.ebuild b/net-irc/bnc/bnc-2.6.4.ebuild
index 0dea891d6105..a17a9ee2a607 100644
--- a/net-irc/bnc/bnc-2.6.4.ebuild
+++ b/net-irc/bnc/bnc-2.6.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.6.4.ebuild,v 1.9 2003/12/29 18:52:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.6.4.ebuild,v 1.10 2004/05/28 02:57:20 vapier Exp $
MY_P=${P/-/}
DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
@@ -11,7 +11,8 @@ SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
+KEYWORDS="x86 ppc sparc alpha arm"
+IUSE=""
DEPEND="virtual/glibc"
@@ -24,8 +25,8 @@ src_compile() {
}
src_install() {
- dodoc CHANGES COPYING README
- dobin bnc bncchk bncsetup bncmkpasswd
+ dodoc CHANGES README
+ dobin bnc bncchk bncsetup bncmkpasswd || die
insinto /usr/share/${MY_P}
doins example.conf motd
}
diff --git a/net-irc/bnc/bnc-2.8.4.ebuild b/net-irc/bnc/bnc-2.8.4.ebuild
deleted file mode 100644
index 08eb04d17a76..000000000000
--- a/net-irc/bnc/bnc-2.8.4.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.4.ebuild,v 1.9 2003/12/29 18:52:20 vapier Exp $
-
-MY_P=${P/-/}
-DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
-HOMEPAGE="http://gotbnc.com/"
-SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz
- http://bnc.ircadmin.net/${MY_P}.tar.gz
- ftp://ftp.ircadmin.net/bnc/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
-
-DEPEND="virtual/glibc"
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- econf || die
- emake || die
- mv mkpasswd bncmkpasswd
-}
-
-src_install() {
- dodoc CHANGES COPYING README
- dobin bnc bncchk bncsetup bncmkpasswd
- insinto /usr/share/${MY_P}
- doins example.conf motd
-}
-
-pkg_postinst() {
- einfo "You can find an example motd/conf file here:"
- einfo " /usr/share/${MY_P}/{example.conf,motd}"
-}
diff --git a/net-irc/bnc/bnc-2.8.6.ebuild b/net-irc/bnc/bnc-2.8.6.ebuild
index b64c0934fcb3..46df777f93b7 100644
--- a/net-irc/bnc/bnc-2.8.6.ebuild
+++ b/net-irc/bnc/bnc-2.8.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.6.ebuild,v 1.12 2004/05/28 02:56:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.8.6.ebuild,v 1.13 2004/05/28 02:57:20 vapier Exp $
MY_P=${P/-/}
DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
@@ -11,7 +11,7 @@ SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~alpha arm"
+KEYWORDS="x86 ppc sparc alpha arm"
IUSE=""
DEPEND="virtual/glibc"
diff --git a/net-irc/bnc/files/digest-bnc-2.6.2 b/net-irc/bnc/files/digest-bnc-2.6.2
deleted file mode 100644
index 1446cb6126a7..000000000000
--- a/net-irc/bnc/files/digest-bnc-2.6.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4fa45cdcda82998f5f73d17cff479a32 bnc2.6.2.tar.gz 42548
diff --git a/net-irc/bnc/files/digest-bnc-2.8.4 b/net-irc/bnc/files/digest-bnc-2.8.4
deleted file mode 100644
index 85270db35f2b..000000000000
--- a/net-irc/bnc/files/digest-bnc-2.8.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 15f197a4f04f2bcc7136ed635bff4afc bnc2.8.4.tar.gz 48400