summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/pcaprub/ChangeLog8
-rw-r--r--dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild19
2 files changed, 19 insertions, 8 deletions
diff --git a/dev-ruby/pcaprub/ChangeLog b/dev-ruby/pcaprub/ChangeLog
index b4a4e3793de8..89a34d4c33a8 100644
--- a/dev-ruby/pcaprub/ChangeLog
+++ b/dev-ruby/pcaprub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/pcaprub
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pcaprub/ChangeLog,v 1.1 2013/12/15 16:25:11 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pcaprub/ChangeLog,v 1.2 2014/01/14 07:36:44 graaff Exp $
+
+ 14 Jan 2014; Hans de Graaff <graaff@gentoo.org> pcaprub-0.11.3-r1.ebuild:
+ Fix broken USE=doc and install additional documentation files. Make build
+ output verbose. Fix dependencies. Add ruby20, ruby21.
*pcaprub-0.11.3-r1 (15 Dec 2013)
diff --git a/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild b/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild
index 9d758b2b3a19..939a435fb587 100644
--- a/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild
+++ b/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild
@@ -1,10 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild,v 1.1 2013/12/15 16:25:11 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pcaprub/pcaprub-0.11.3-r1.ebuild,v 1.2 2014/01/14 07:36:44 graaff Exp $
EAPI=5
-USE_RUBY="ruby19"
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="FAQ.rdoc README.rdoc USAGE.rdoc"
+
inherit multilib ruby-fakegem
DESCRIPTION="Libpcap bindings for ruby compat"
@@ -14,14 +18,17 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-DEPEND="net-libs/libpcap"
-RDEPEND="${DEPEND}"
+DEPEND+="net-libs/libpcap"
+RDEPEND+="net-libs/libpcap"
+
+# Tests require live access to a network device as root.
+RESTRICT="test"
each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die
}
each_ruby_compile() {
- emake -C ext/${PN}
+ emake -C ext/${PN} V=1
cp ext/${PN}/${PN}$(get_modname) lib || die
}