summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog8
-rw-r--r--app-accessibility/dasher/dasher-4.0.3.ebuild71
-rw-r--r--app-accessibility/dasher/files/dasher-4.0.3-intl_fix.patch11
-rw-r--r--app-accessibility/dasher/files/digest-dasher-4.0.33
4 files changed, 92 insertions, 1 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 3ccf9a403460..3f17580aea1e 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.67 2006/07/17 14:40:41 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.68 2006/07/31 08:38:43 leonardop Exp $
+
+*dasher-4.0.3 (31 Jul 2006)
+
+ 31 Jul 2006; Leonardo Boshell <leonardop@gentoo.org>
+ +files/dasher-4.0.3-intl_fix.patch, +dasher-4.0.3.ebuild:
+ Version bump.
17 Jul 2006; Daniel Gryniewicz <dang@gentoo.org> dasher-4.0.2.ebuild:
Marked stable on amd64 for bug #139612
diff --git a/app-accessibility/dasher/dasher-4.0.3.ebuild b/app-accessibility/dasher/dasher-4.0.3.ebuild
new file mode 100644
index 000000000000..b51dd58cbdd8
--- /dev/null
+++ b/app-accessibility/dasher/dasher-4.0.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.0.3.ebuild,v 1.1 2006/07/31 08:38:43 leonardop Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility gnome cairo"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND="dev-libs/expat
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=dev-libs/glib-2
+ >=x11-libs/libwnck-1
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXtst )
+ virtual/x11 )
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1 )
+ cairo? ( >=x11-libs/gtk+-2.8 )"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt )
+ virtual/x11 )
+ >=dev-util/intltool-0.28
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+
+pkg_setup() {
+ G2CONF="$(use_with gnome) \
+ $(use_enable accessibility a11y) \
+ $(use_enable accessibility speech) \
+ $(use_with cairo)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix i18n handling when USE=-gnome is used
+ epatch "${FILESDIR}"/${P}-intl_fix.patch
+
+ # fix configure flags
+ epatch "${FILESDIR}"/${PN}-4.0.2-fix_enable_flags.patch
+
+ eautoreconf
+}
diff --git a/app-accessibility/dasher/files/dasher-4.0.3-intl_fix.patch b/app-accessibility/dasher/files/dasher-4.0.3-intl_fix.patch
new file mode 100644
index 000000000000..e61e977bbf3b
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.0.3-intl_fix.patch
@@ -0,0 +1,11 @@
+diff -NurdB dasher-4.0.2/Src/main.cc dasher-4.0.2-patched/Src/main.cc
+--- dasher-4.0.2/Src/main.cc 2006-02-25 16:19:10.000000000 -0500
++++ dasher-4.0.2-patched/Src/main.cc 2006-05-09 20:10:45.000000000 -0500
+@@ -1,6 +1,7 @@
+ #include "Common/Common.h"
+ #include "AppSettings.h"
+
++#include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdkx.h>
+ #include <glade/glade.h>
diff --git a/app-accessibility/dasher/files/digest-dasher-4.0.3 b/app-accessibility/dasher/files/digest-dasher-4.0.3
new file mode 100644
index 000000000000..048f9954669d
--- /dev/null
+++ b/app-accessibility/dasher/files/digest-dasher-4.0.3
@@ -0,0 +1,3 @@
+MD5 055994e0cce2c05c21d10b64fa84a90c dasher-4.0.3.tar.bz2 5706380
+RMD160 150eec2e2916f62f295882bd83f75616b8e17f1a dasher-4.0.3.tar.bz2 5706380
+SHA256 85630ac6943caf68e90fa92fdba6bc927a80ec01ca083ab3e7baa9594699eb39 dasher-4.0.3.tar.bz2 5706380